Problem when upgrading kernels

as 5.13.1 is available i wanted to upgrade to it. When booting I am greeted with
the root device is not configured to be mounted read-write it may be fsckd again later
I already tried putting in rw in my kernel command line (extra_kernel_version_strings linux rw in boot/efi/EFI/refind/refind.conf, using refind) but the message still appears. 5.12 boots fine, and DKMS nvidia drivers didnt report problems on the upgrade, so its not them. Any suggestions on what i could try?

ok narrowed it down to some refind problem. if i manually add rw it works. will ask somewhere else ig

there was an extra refind.conf in /boot, edited the kernel parameters to rw instead of ro. Can boot newer kernel now

That file would be /boot/refind_linux.conf for automatic detected kernels by refind. See Arch Wiki

I’ll go ahead marking this thread as solved for you. No need to add a tag for this on the topic’s title.

For future threads, you can do so by clicking on the “hamburger” (similar to the Ellipsis mark) icon at the bottom of the post (except for the OP.). The solution option should be hidden there. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.