Problem tlp.service longtime booting and longtime shutdown - Gnome

I’m a new user manjaro, gnome. I like the rolling release and the availability of the latest software versions. I have a big problem due to longtime booting and longtime shutdown and the first launch of any application takes too long.

systemd-analyze blame
52.450s tlp.service
 6.059s plymouth-quit-wait.service
 2.909s upower.service
  577ms snapd.service
  479ms lvm2-monitor.service
  285ms apparmor.service
  229ms systemd-random-seed.service
  202ms dev-sda2.device
  178ms systemd-journal-flush.service
  169ms udisks2.service
  143ms cups.service
  121ms polkit.service
  120ms user@1000.service
  103ms ldconfig.service
   68ms systemd-journald.service
   67ms NetworkManager.service
   67ms boot-efi.mount
   61ms systemd-logind.service
   60ms systemd-udev-trigger.service
   60ms geoclue.service
   49ms systemd-udevd.service
   43ms systemd-timesyncd.service
   41ms ModemManager.service

  Kernel: 5.4.105-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
  root=UUID=----------------- ro quiet splash apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: GNOME 3.38.4 tk: GTK 3.24.27 wm: gnome-shell dm: GDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0
  serial: <filter>; UEFI: American Megatrends v: 1.D0 date: 11/07/2019
  Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache:
  L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 118420
  Speed: 2008 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz):
  1: 2008 2: 1725 3: 1930 4: 2453 5: 2062 6: 2069 7: 2052 8: 2064 9: 2026
  10: 2411 11: 1888 12: 1890 13: 1894 14: 1889 15: 2828 16: 2071
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: XFX Pine
  driver: amdgpu v: kernel bus-ID: 28:00.0 chip-ID: 1002:7340 class-ID: 0300
  Display: x11 server: 1.20.10 compositor: gnome-shell driver:
  loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
  resolution: <missing: xdpyinfo>;
  OpenGL: renderer: Radeon RX 5500 XT (NAVI14 DRM 3.35.0 5.4.105-1-MANJARO
  LLVM 11.1.0)
  v: 4.6 Mesa 20.3.4 direct render: Yes
  Device-1: AMD Navi 10 HDMI Audio vendor: XFX Pine driver: snd_hda_intel
  v: kernel bus-ID: 28:00.1 chip-ID: 1002:ab38 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 2a:00.3 chip-ID: 1022:1457
  class-ID: 0403
  Sound Server-1: ALSA v: k5.4.105-1-MANJARO running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: yes
  Sound Server-4: PipeWire v: 0.3.23 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>;
  Device-2: D-Link DWA-121 802.11n Wireless N 150 Pico Adapter [Realtek
  type: USB driver: rtl8192cu bus-ID: 1-8.4:4 chip-ID: 2001:3308
  class-ID: 0000 serial: <filter>;
  IF: wlp3s0f0u8u4 state: down mac: <filter>;
  Local Storage: total: 1.59 TiB used: 31.33 GiB (1.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B
  speed: 6.0 Gb/s rotation: SSD serial: <filter>; rev: 2B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD105
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter>; rev: A8J0 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
  model: WD10EADS-11M2B2 size: 931.51 GiB block-size: physical: 4096 B
  logical: 512 B speed: 3.0 Gb/s serial: <filter>; rev: 0A80 scheme: MBR
  ID-1: / raw-size: 232.59 GiB size: 227.94 GiB (98.00%)
  used: 31.33 GiB (13.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No Swap data was found.
  System Temperatures: cpu: 42.8 C mobo: N/A gpu: amdgpu temp: 29.0 C
  mem: 0.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 347 Uptime: 42m wakeups: 0 Memory: 15.65 GiB
  used: 2.37 GiB (15.2%) Init: systemd v: 247 tool: systemctl Compilers:
  gcc: 10.2.0 Packages: pacman: 1443 lib: 419 flatpak: 0 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.03


Since you have

then you can remove tlp
pamac remove tlp
sudo pacman -R tlp
then reboot your system.

Thanks, it’s a little faster booting, but still slow. Now some other services have extended the boot time.

systemd-analyze blame                                           
16.487s systemd-hostnamed.service                            
16.441s systemd-localed.service                              
 3.978s plymouth-quit-wait.service                           
  934ms upower.service                                       
  662ms snapd.service                                        
  483ms lvm2-monitor.service                                 
  298ms apparmor.service                                     
  224ms systemd-random-seed.service                          
  204ms dev-sda2.device                                      
  187ms systemd-journal-flush.service                        
  157ms udisks2.service                                      
  131ms boot-efi.mount                                       
  130ms user@1000.service                                    
  123ms cups.service                                         
  108ms polkit.service                                       
   94ms ldconfig.service                                     
   72ms systemd-journald.service                             
   66ms NetworkManager.service                               
   60ms systemd-logind.service                               
   57ms systemd-timesyncd.service                            
   53ms systemd-udev-trigger.service                         
   50ms systemd-udevd.service                                
   49ms geoclue.service

hostnamed is responsible for your hostname. the long start time might be related to a error in the hostname setting? (dhcp issue?)

Localed is setting up locales for your system, are your locale settings correct?

Does your journal say anything about these services?
(eg: journalctl --boot --priority=err )

I wonder why systemd thinks these services are to blame for a slower boot. If I take my own system (regular desktop, stable manjao gnome) the systemd-hostnamed & systemd-lolcaled are not blocking anything in the boot proces. Es example my data and status of these services:

systemd-analyze blame                                                                                                                          ✔ 
3.558s NetworkManager-wait-online.service                                                       
3.536s plymouth-quit-wait.service                                                               
1.400s lvm2-monitor.service                                                                     
1.295s systemd-random-seed.service 

systemctl status systemd-hostnamed.service

apr 04 11:46:07 gid systemd[1]: Starting Hostname Service...
apr 04 11:46:07 gid systemd[1]: Started Hostname Service.
apr 04 11:46:41 gid systemd[1]: systemd-hostnamed.service: Succeeded.

systemctl status systemd-localed.service

apr 04 11:46:10 gid systemd[1]: Starting Locale Service...
apr 04 11:46:10 gid systemd[1]: Started Locale Service.
apr 04 11:46:41 gid systemd[1]: systemd-localed.service: Succeeded.