Problem running DX12 games on nvidia/intel hybrid laptop

My hardware consists of an an 8th generation i7 with a gtx1060 maxq.

I have tried several DX12 titles in the past and none of them work. In the current steam sale, I am considering buying Resident Evil Village. I have the Demo installed, and it loads to a black screen.

I have vkd3d and vkd3d-proton-git installed.
My system is up to date using the recommended, default intel/nvida hybrid setup in manjaro hardware config. My kernel is 5.15.7-1-MANJARO. I have tried many current and older proton and proton ge versions.

According to protondb, for most people it just works. One user suggested a launch argument

PROTON_ENABLE_NVAPI=1 VKD3D_CONFIG=dxr11 gamemoderun %command%

For me this just caused the game not to launch at all.

Some googling led me to a terminal command that supposedly will enable me to use DX12 until reboot.

sudo nvidia-modprobe -u -c=0

This command didn’t seem to change anything at all.

Any ideas on how to get DX12 titles going?


Edit: I should also mention that I am using the KDE version of Manjaro.

can you probe this



Still black screen when launching the demo.

Proton Experimantal or Proton 6.3-8 ?


I quickly tried both of those, plus the latest proton ge 7.0-rc2 I believe it is.

i load the demo

1 Like

Thanks a lot!

i search (demo on load)

Go to Pamac an search for vkd3d
i hope you must install and it works ?

without this pakage the Option VKD3D_CONFIG=dxr11 has no effect

I have the aur version of this installed already

I will try that package option. It was included in the first command, but I will try it by itself.

It has not worked so far with or without VKD3D_CONFIG=dxr11

I just installed a few different versions of vkd3d-proton. Still black screen lol.

The Game works great.

I have not installed vkd3d

Only Steam and Proton 6.3-8 without any commands in commandline
Blackscreen for 1min and the game works

1 Like

Ha, maybe I am just not waiting long enough. I will try that lol. I will let you know if it starts.

LOL Thanks a lot for the help. It look me a little bit longer than a minute, because I have my CPU set at 60% of max frequency for gaming. I can’t believe it. I need to learn some patience.

perfect :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.