Problem rendering Arabic letters in the terminal

Hello, I apologize if this is not the right place to ask.
I have an issue related to displaying Arabic characters in the terminal. My default system language and format is set en_US.utf8. Arabic language works fine with graphical apps, but the terminal gives me weird characters if I attempt to read an Arabic file. I have tried with Konsole, Terminator and Termite. They all have the same issue. So I assume it’s not related to a specific emulator. I have played with different encoding profiles in Konsole but it didn’t solve the issue.
Any help would be appreciated

AUR (en) - bicon-git
Afaik, only konsole has integrated bidirectional input support.

No idea whether bicon will work with eg. vim (or wherever you intend to use this)

from Typing Arabic in gnome-terminal / Newbie Corner / Arch Linux Forums

I mainly use it in Newsboat which is a terminal RSS reader. The terminal displays question marks instead of characters when displaying Arabic. I used basically the same setup in a previous laptop and it worked fine.

terminal charset are defined in /etc/vconsole.conf.