Problem mounting network drive


New PC, clean Manjaro KDE install. Trying to mount a network drive with the following fstab entry:

//wdmycloud/Public /mnt/nas cifs username=anonimous,password=,iocharset=utf8,dir_mode=0777,file_mode=0777,rw 0 0

After booting, when I try to access /mnt/nas from Dolphin, it doesn’t work and the following error is displayed:

An error occured while accessing 'mnt/nas', the system responded: mount.cifs: permission denied

However, if I do ‘sudo mount -a’ then the ntwork drive is mounted and works OK. The very same fstab entry worked OK on my old pc. What can be the problem?


Are you using a WIFI network on your PC?

It is possible that the network is not available at the time that mount is attempted, but is by the time you type sudo mount -a

No, this is a wired connection.

are you sure the username is correct?

1 Like

New info: during boot, right before login screen appear, the following text is displayed:

[FAILED] Failed to mount /mnt/nas
[DEPENDENT] Dependency failed for remote file system.

Help will be appreciated. TIA.

Yes. Also tried NAS admin user/pass, same response.

Well, I found a stupid solution by creating a cron job that executes mount -a after boot. It works, but will nice to have a proper solution, if anyone knows.

Thanks to all that helped.

Once again, are you sure it’s correct? Because, that spelling is wrong.

Else, see


Hi Mirdarthos,

True, the spelling was wrong. However, fixing it or using the real user/password for the NAS device yields same result.

I will look at the other stuff and see if it works.