Problem migrating from Windows

So, I’m trying to install Manjaro XFCE on my PC, and I’m actually writing this from which I believe is Manjaro Live. The issue is, the installer is stuck on this message > Waiting for 1 module. (600 sec - and up). I tried restarting and changing the USB flash drive, but it doesn’t seem to work. Should the installation take long Its my first time trying Linux, ive been wanting to do so for a long time, id appreciate the help.

Change SATA mode from IDE to AHCI in your BIOS.


It worked, but it didn’t. After I chose the location it closed. I tried running it again, but now I’m stuck again.

OK, then let’s start to try to find the reason.

Do you use an USB 2.0 or 3.x port?
Are you using a fast or slow USB stick?
Have you checked the checksum of the ISO you burned to the USB stick?
Is this a dual boot situation with another OS?
Is your system booting UEFI or BIOS (legacy)?
Is your disk partitioned in msdos (with MBR) or gpt mode?
Can you run the ISO and apply some commands before starting the installer, such as

inxi -Fxxxza --no-host
sudo parted -l
sudo efibootmgr -v

Please, post output here, Put it between lines with ~~~ to format it nicely.

USB 2.0, no dual boot, UEFI. The other questions I don’t know how to answer :confused:

Error 22: Unsupported option: --no
Check -h for correct parameters.
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  556MB  555MB   ntfs         Basic data partition          hidden, diag
 2      556MB   661MB  105MB   fat32        EFI system partition          boot, esp
 3      661MB   677MB  16.8MB               Microsoft reserved partition  msftres
 4      677MB   120GB  119GB   ntfs         Basic data partition          msftdata

sudo efibootmgr -v 
Model: ATA TOSHIBA DT01ACA1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  525MB   524MB  primary  ntfs         boot
 2      525MB   371GB   370GB  primary  ntfs
 3      371GB   371GB   498MB  primary  ntfs         msftres
 4      371GB   1000GB  629GB  primary  ntfs

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdd: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2814MB  2818MB  4194kB  primary               esp

[manjaro@manjaro ~]$ 
[manjaro@manjaro ~]$ sudo efibootmgr -v
BootCurrent: 0006
Timeout: 2 seconds
BootOrder: 0006,0004,0005,0001,0000
Boot0000* Cartão Network 	BBS(Network,,0x0)AMGOAMNO........i.A.t.h.e.r.o.s. .B.o.o.t. .A.g.e.n.t.........................rN.D+..,.\...........:..Gd-.;.A..MQ..L.A.t.h.e.r.o.s. .B.o.o.t. .A.g.e.n.t......AMBO
Boot0001* Disco Rigido 	BBS(HD,,0x0)AMGOAMNO........o.K.I.N.G.S.T.O.N. .S.A.4.0.0.S.>..Gd-.;.A..MQ..L. . . . ......AMBOAMNO........o.T.O.S.H.I.B.A. .D.T.0.1.A.C.A.1.0.0....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . .5. .2.3.K.A.E.T.S.N......AMBO
Boot0004* Windows Boot Manager	HD(2,GPT,835b541b-d76f-4e00-bb65-780e63a184a5,0x109000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...,................
Boot0005* Dispositivo Desconhecido 	BBS(11,,0x0)AMGOAMNOy.......W.S.a.n.D.i.s.k....................A.............................$..Gd-.;.A..MQ..L.S.a.n.D.i.s.k......AMBO
Boot0006* UEFI: SanDisk	PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(3,0)/HD(1,MBR,0x0,0x53dd0c,0x2000)AMBO
[manjaro@manjaro ~]$ 

Sorry, there was a typo, first command should be

inxi -Fxxxza --no-host

Again, have you checked the checksum of the ISO when burned to the stick? This is crutial.

There is no space left, you should make space for a Manjaro partition.

No, I didn’t, I don’ know how to do that.

           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=br tz=UTC misobasedir=manjaro 
           misolabel=MANJARO_XFCE_202 quiet systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 
           Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: POSITIVO product: POS-EIH61CE v: 3050_POS8 serial: <filter> 
           Mobo: Positivo Informatica SA model: POS-EIH61CE v: POSITIVO serial: <filter> 
           UEFI: Desenvolvida para Positivo Informatica SA v: 4.6.5 date: 05/03/2013 
CPU:       Info: Quad Core model: Intel Core i5-3330 bits: 64 type: MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23954 
           Speed: 1596 MHz min/max: 1600/3200 MHz Core speeds (MHz): 1: 1596 2: 1597 3: 1596 4: 1596 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics vendor: Elite Systems driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0152 
           Display: x11 server: X.Org 1.20.10 driver: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 
           screens: 1 
           Screen-1: 0 s-res: 1360x768 s-dpi: 96 s-size: 359x203mm (14.1x8.0") s-diag: 412mm (16.2") 
           Monitor-1: VGA1 res: 1360x768 hz: 60 dpi: 84 size: 410x230mm (16.1x9.1") diag: 470mm (18.5") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa 20.2.3 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Elite Systems driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: Elite Systems driver: atl1c v: kernel port: e000 
           bus ID: 02:00.0 chip ID: 1969:2062 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 142.9 MiB (0.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s serial: <filter> rev: 71E0 scheme: GPT 
           ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 1.5 Gb/s rotation: 7200 rpm serial: <filter> rev: A750 scheme: MBR 
           ID-3: /dev/sdd type: USB vendor: SanDisk model: Cruzer Blade size: 14.91 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: N/A size: 4.11 GiB used: 142.9 MiB (3.4%) fs: overlay source: ERR-102 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 209 Uptime: 40m Memory: 5.48 GiB used: 1.37 GiB (24.9%) Init: systemd v: 246 Compilers: gcc: N/A 
           Packages: pacman: 1166 lib: 327 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08 

Google is your friend to find out. The checksum is provided at the same location as the downlaod.

Okay, took me a while, but I managed to do that (thanks for teaching me a new thing!) and it matches!

1 Like

Any plan to change that? :upside_down_face:

I have no idea how to fix that :thinking: I thought my computer had alot of free memory… Or is it the USB? Should I just reset Windows?

Your partition /dev/sda4 has a size of 119 GiB and is formatted in ntfs. If that’s the partition you want to use reformat it into ext4. If there are files on that partition you want to save, do this upfront, of course!

Is that the total memory my system will have? My PC has close to 1TB. I saw that I have GParted here on the Manjaro Live, will try that out.

1 Like

So, I ran mkfs.ext4 and still the same problem :thinking:, and GParted doesn’t load.

mke2fs 1.45.6 (20-Mar-2020)
/dev/sda4 contains a ntfs file system
Proceed anyway? (y,N) y
Discarding device blocks: done                            
Creating filesystem with 29139712 4k blocks and 7290880 inodes
Filesystem UUID: e073b370-a504-4310-9fa1-9151036c7466
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (131072 blocks): done
Writing superblocks and filesystem accounting information: done   
    Remaining modules: 1 

This is where I would start from scratch to avoid compounding errors.

Make your stick with USB Flasher - it will let you do the checksum - it’s in manjaro
Use gparted and blow away the SSD drive, and on it, then

Make a small FAT32 (512Mb) partition for /boot/efi
Be sure to mark it bootable with gparted
Make a swap partition if you don’t have at least 16 GB RAM
Make a root partition - I use about 50GB - ext4
(I use the other half of the SSD for another OS)

Switch to a separate disk and
Make a /home partition - ext4

Run the install and choose “Something else” from the install options
Assign the above 4 partitions

I have Windows 10, Manjaro Cinnamon and (currently) MX-19 running on this box
Does this help?

Is it normal for GParted to take a long time to scan all devices?