Problem installing manjaro with f2fs format

Hello here,

Trying yesterday to install manjaro xfce desktop on my Lenovo laptop x260 (2017), and after 2 hours having the same problem : grub-install error code 1 (which seems to be no permission for creating files), I finally discover that in ext4 format it works, and in f2fs it doesn’t.

I have the same problem with manual partition, and automatic install.

Before, I was with arch Linux distro and f2fs works well.

It’s probably me doing something bad because i’m not a ninja Linux (yet), but I post this here anyway, maybe it would help someone else trying to install manjaro with f2fs format. Now i’m fine with ext4 and I will stick with it.

Im new to this forum so sorry if it’s not the good place to post this, and again sorry for the bad english, I do my best !

Best regards,

There is no such filesystem as n2fs, so I can only guess that you mean either ntfs or f2fs. ntfs is the proprietary Microsoft filesystem used by Microsoft Windows, while f2fs is a log-structured filesystem created by Samsung for flash-based storage (such as SSDs).

GNU/Linux cannot be installed on ntfs because it is a UNIX operating system, which requires filesystems that support POSIX file ownership and permissions, which ntfs does not support and cannot store.

f2fs on the other hand is a POSIX filesystem, but the GRUB boot loader will probably need special support for that — I do not think the standard GRUB used by Manjaro supports f2fs — and as such, you might be better off using something like systemd-boot if you’re going to dabble with f2fs.

Further reading, albeit only tangentially relevant… :arrow_down:

systemd-boot at the Arch Wiki

Thanks for your quick answer. I mean f2fs not n2fs, I corrected my post.
My laptop have an 250Gb SSD, so this is why I have try f2fs, but I don’t know well this format. So thanks you very much for the ressources.

For the boot/grub partition, I have created a special parts of 300Mib, in fat32 format, and flagged as boot + bios-grub. And even with that, I have the error one of grub-install (with f2fs format for root and home partition, in ext4 again it works).
I thinks the automatic install of Calamares create also this special part, but in f2fs it does not work and with ext4 its okay. Maybe we have to format ourselves the disk into a f2fs before starting installation ?

Just because you have an SSD does not mean you need f2fs, though. ext4 or btrfs are just as good with SSDs, and both have performance optimizations for SSDs.

The reason that (Manjaro’s) GRUB has a problem with your setup is that, even though you have a dedicated EFI partition, GRUB still needs to be able to read /boot, which itself would be on the f2fs root filesystem in your case, and I think Manjaro’s GRUB doesn’t support that — or at least, not out-of-the-box, and it takes quite a bit of tinkering (and knowing what you’re doing) to include that support.

By the way, the EFI partition needs the esp flag, not bios_grub — that’s for the empty 2 MiB partition if your system boots in legacy BIOS mode instead of in EFI mode.

I thinks I understand, so in my case I should have set the root partition / in ext4 so that GRUB can read /boot ? And after that, we can for example set the /home partition in f2fs and it should work ?

Yeah I thinks ext4 is fine, for now I will stick with it, maybe for a future installation I will try this way.

But what is strange is that the automatic installation of Calamares in f2fs does not take this into account either.
Anyway, thanks you for the good explanation

Yes, or create a separate /boot partition with ext4 in addition to the /boot/efi partition.

Yes, once the kernel is loaded, f2fs is fully supported.

Well, the Calamares developers rather make mistakes than listen to good advice from an experienced user. Trust me — been there, done that… :roll_eyes:

You’re welcome. :beers:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.