Problem installing Manjaro on a SSD disk where windows used to be

I have an acer Nitro 5 laptop.

I installed Manjaro on a 1TB SSD because the other 256GB SSD faster (Windows) did not appear in the first place, due to compatibility problems in the BIOS that I solved later. So I installed Manjaro in the slower disk while troubleshooting.

I want to have the highest possible speed when booting, so I want to install Manjaro on the fast disk.

I already tried many times but it always gave me an error when booting, I tried making the partitions automatically and manually like this.

*GPT *

  • 300 Mib ----- FAT32 ------ / boot/efi - boot flag
  • 8192 MiB — linuxswap ----------------- swap flag
  • 51200 MiB - ext4 --------- / -------------- root flag
  • rest ------------ ext4 ---------- /home

I heard on a site that it was necessary to leave at least 8Mib free for /Bios/Grub, on GPT format disks so I tried that too and nothing.

With the automatic partitioning of the installer with/without swap and with/without hibernation but neither. (to put the SWAP once I could use GParted with the system running)

When I boot from the fastest disk, once I finish the installation it sends me to an emergency console. that is, I can’t even enter the installed system. This error does not appear in the slower disk (From I’m running Manjaro right now)

Instead of being called SDB or SDA, the disk is called nvme0n1 with p1 (Single partition ext4 238,5Gb) and I don’t know how to change that name.

the problem could also be a driver error from Nvidia but I tried with free drivers and it didn’t allow me to pass at least the emergency terminal. So I couldn’t use nano.

If there is a possibility to migrate my current customization on the slow disk to the fast disk, like cloning it or something like that, it would help me.

Thanks a lot!