Private Internet Access (PIA) - VPN Connection Issue

I use PIA-VPN (with subscription) and the Linux client downloaded from their site.

<–I tried to post a link to the PIA site here, but I was not allowed–>

The client installs without any problem, and the setup is flawless. It also connects to a VPN-server and works as expected, but only for about 4-5 minutes. If I look at my network adapter when it works as expected it initially says: “Wired Ethernet: Connected to Wired connection 1”, but then after the 4-5 minutes it adds a little star on the network icon and the information now is: “Wired Ethernet: Connected to Wired connection 1 (limited connectivity)”. There is no change or error message in the VPN-Client interface, it still says connected (see also attached desktop screen dump). In order to get my connection back to normal I have to disconnect the VPN-Client from it’s server, and then reset the network adapter. Then everything is back to normal. I have been in contact with the PIA support, and they suggested me to try to change UDP/TCP-ports used by the client, but that had no effect on the behavior. I have also tried both WIFI and Ethernet cable, but the problem is the same.

Is there anything else that can be changed so that the VPN-client can be working as expected, without the network switching to the “limited connectivity” state after just 4-5 minutes? Anyone having any idea what could be the problem here?

System info:

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: Z390 I AORUS PRO WIFI v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: Z390 I AORUS PRO WIFI-CF serial: <filter> 
  UEFI: American Megatrends v: F5d date: 01/16/2019 
CPU:
  Topology: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP 
  arch: Kaby Lake rev: C L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57616 
  Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e98 
  Display: x11 server: X*Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: 
  1: 1920x1080~60Hz 2: 2560x1440~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: Z-Star Micro A4 TECH HD PC Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-8:3 chip ID: 0ac8:3500 
  serial: <filter> 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 85.86 GiB (7.4%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB 
  size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: 1B2QEXM7 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: CC43 scheme: GPT 
Partition:
  ID-1: / size: 43.95 GiB used: 14.14 GiB (32.2%) fs: btrfs 
  dev: /dev/nvme0n1p6 
  ID-2: /home size: 43.95 GiB used: 14.14 GiB (32.2%) fs: btrfs 
  dev: /dev/nvme0n1p6 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 335 Uptime: 1d 1h 34m Memory: 31.23 GiB 
  used: 3.19 GiB (10.2%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: pacman: 1300 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05

PIA-VPN-Client version: 2.4 (build 05574)

Screen dump 1: Just connected to VPN, and everything is OK.
<–I tried to upload a screen dump here, but I was not allowed–>

Screen dump 2: After 4-5 minutes connection is not OK anymore.
<–I tried to upload a screen dump here, but I was not allowed–>

When you have the ‘connectivity limited’ issue, is there an actual issue? Something not working?

Yes there is really a “limited” connectivity. For example Spotify does not work (it says “offline”).

[UPDATE]

Log (journalctl): From connection to the VPN (at 09:01:43) to the change in status to “limited connectivity” (at 09:01:47)

okt 18 09:01:43 NetworkManager[47335]: [1603004503.0232] manager: (tun0):
new Tun device (/org/freedesktop/NetworkManager/Devices/5)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0325] device (tun0): st
ate change: unmanaged -> unavailable (reason ‘connection-assumed’, sys-iface-state
: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0338] device (tun0): st
ate change: unavailable -> disconnected (reason ‘connection-assumed’, sys-iface-st
ate: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0342] device (tun0): Ac
tivation: starting connection ‘tun0’ (6ff14070-0aa8-4934-a9b1-b63759d0105e)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0343] device (tun0): st
ate change: disconnected -> prepare (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0344] device (tun0): st
ate change: prepare -> config (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0346] device (tun0): st
ate change: config -> ip-config (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0347] device (tun0): st
ate change: ip-config -> ip-check (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0446] device (tun0): st
ate change: ip-check -> secondaries (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0447] device (tun0): st
ate change: secondaries -> activated (reason ‘none’, sys-iface-state: ‘external’)
okt 18 09:01:43 NetworkManager[47335]: [1603004503.0453] device (tun0): Ac
tivation: successful, device activated.
okt 18 09:01:47 NetworkManager[47335]: [1603004507.1519] manager: NetworkM
anager state is now CONNECTED_SITE

[2020-10-18 FINAL UPDATE]

Swiched to Ubuntu, ditched Manjaro!

Reason: Manjaro has always caused me a lot of problems, and constantly requires a lot of “fixes” to run. I am so tired of this!!

Obviously Ubuntu is the way to go if you want a Linux that works “out of the box”!

So, Bye bye Manjaro and Hello Ubuntu!

Regarding your childish attitude when you don’t get an answer 24h after you open a thread, indeed, it may be preferable that you continue not learning anything and change the whole operating system because of an external program Manjaro has no control over…

:expressionless:

And of course make a scene and cry out loud false facts in the process…

Farewell, have fun having other problem you’ll never understand and solve on other OS (because that will happen).

//EDIT: install the client from the AUR instead of manualling installing the client from website probably would solve the issue, issue also known as the PEBKAC syndrome, probably.

1 Like

Well, now we can wait and see if there is any solution to this network and VPN issue published here…(and BTW it is NOT caused by the PIA-client, it is a generic issue).

What? Did you reinstall Manjaro now?

Just curious if there is any solution…(what is the Manjaro issue, when it is working just fine on Ubuntu. PIA support guys are also wondering).

Maybe instead of ditching the OS and ignoring the suggestion you could… you know… try.

But you already made you mind, ditched Manjaro, and already know it is not an issue with the PIA client so why did you even open this thread for, and bump it again today after the drama? So what now? It is a “generic” issue what does that even mean?

This thread makes no sense and probably going nowhere.

The issue is not with the PIA-VPN client only, also tried the IVACY-VPN client. Same issue there.

Did you try piavpn-bin?

Also you could have checked if your vpn client was being blocked somehow in the firewall. The “report” tab shows if any connections are being blocked or allowed.

Intended to, but after reading all of the issues published there, I did not.

You should have had. It installs for me. I don’t have subscription to this vpn (I use protonvpn), so don’t know if it works. But the installation is fine.

Checked that, it was not the issue.

maybe fire up a manjaro virtual machine and check with the piavpn-bin from aur? If the problem persists then it would make sense to investigate further.

I was running PIA for a while on Manjaro but recently switched to nord, it occasionally dropped signal for me but not often and it was only a case of toggling wifi on and off to fix it.

You used the officila PIA install .sh ? There are several PIA tools in the AUR that may help like PIA manager and PIA tools

They are not updated (also with these there are issues published).

The guy doesn’t want to solve his issue, he wants to complain that Manjaro has all the issues. Already suggested multiple time to install from the AUR instead of manually from website.
Third time the charm they say?

2 Likes