Printing in color not working any more (SOLVED)

Hi,

I am using the printer Koycera ECOSYS P5021cdn via network. Today I wanted to print something in color but the print was in grayscale. I did following things but which not helped:

  • Readded the printer with the PPD file
  • Checked the printer setting → set to “color” but seems not to be stored
  • Printed a test page
  • Added the printer directly via CUPS with PPD file
  • Printed from various applications

Color print works when printing into files PDF and PS.

Remarkable is that when I set the color setting of the printer to “color” its not stored and when I check it again ist “black/white” again.

I have a second Manjaro system, which wasn’t updated for some months and here the testpage is fine.

So I checked some package versions:

Good system:
CUPS 1:2.4.1-1
system-config-printer 1.5.16-1
manjaro-printer 20220314-1

Bad system:
CUPS 1:2.4.2-3
system-config-printer 1.5.16.-1
manjaro-printer 20220314-1

I have no clue where the problem is coming from.

Thanks in advance.

Regards

1 Like

Hi,

some new info:

  • Downgrade of CUPS has no effect
  • Printing a test page out of system-config-printer is colored

At the moment I am updating the other older system. I will see if the system will have the same problems too.

Regards

Hi,

latest info:
My old notebook is now at the same package level as my actual. Funny is, my old notebook still have the correct “color” setting of the printer and can print in color.
EDIT: When I add a the printer as a new one it have the same issue that it will not keep default color mode.

My actual notebook does not keep the setting in gnome control center. I tried reinstalling the printer via gnome and CUPS, no success so far.

Its a little bit frustrating.

Regards

Hi,

I got it. Solution was an option only visible in

system-config-printer

There was a second color option within the advanced job options, called “print-color-mode” which was set to “monochrome”. After setting it to “color”, I was able to set color mode in the classic printer settings.

What a journey …

Maybe this will help others with same problems in future.

Regards.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.