Printing 11x17 options not there, epson printer lxqt

My brother just got an epson wf-7840 specifically because it can print 11x17 for his autocad work. He’s using a laptop I loaned him with manjaro lxqt. We installed the epson-inkjet-printer-escpr2 from the AUR which is slightly out of date but worked and it does print.
The problem is he doesn’t have an option in the printer options to use 11x17. Anyone know how to enable this paper size?

Did you try the built-in definitions from the standard repository first?

If not: uninstalll the AUR package and then just add your printer and if that fails or you did try standard first, try looking for a more recent PPD file.

(This is generic information on how to install printers under Linux: I don’t have your hardware, so can’t give you specific instructions)


1 Like

We tried without aur first. It printed gibberish then spit out every paper in the tray one at a time.
Epson has a Linux printer driver that is more recent than the aur. but they only have rpm and Deb packages.
They do have one called rpm source. Is that something we can build with on manjaro?
I tried debtap but I couldn’t get the lsb dependency to resolve even with the fake lsb package.
Any suggestions?

If you’ve never built anything from source, you’re going to be better off contacting the package maintainer of your current package and informing them that there is a newer package available. (You should be able to leave a comment on the AUR)

If you don’t get a response within 24 hours, the package might be unmaintained, and if you’ve ever compiled anything, head over to the wiki for specific Manjaro instructions and how to get the package you’re building into the Manjaro repository so that no one will run into the same issues that you’re running into in the future.

And if you do, welcome to the Manjaro contributor group!