Printers not working specifically in KDE

I recently decided to switch from Cinnamon to KDE as my main desktop environment. Every time I try to set up printers using KDE, though, I can’t get them actually to print even though they worked fine in Cinnamon. I have a Canon TS9120 at home and a few different Sharp printers at work that I’m trying this on, and I’m running into the same problem on all of them.

Here’s what I’ve tried.

  • Setting up the printers over the network using the KDE printer setup utility
  • Setting up the printers over the network using system-config-printer (This is what I did with Cinnamon, and I did exactly the same thing I did when setting things up in Cinnamon, where it worked, but no luck in KDE)
  • Setting up my Canon printer at home using a USB cable and system-config-printer

In all three cases, my printer responds to print requests (I get a “Printing” message on the Canon), but no actual printing takes place.

Does anyone have an idea of why this would all work in Cinnamon but not KDE and which log files I might look at in order to figure out the problem?

CUPS should be DE agnostic, maybe only have a little GUI config helper but that’s all. For sure, my HP printer works fine in KDE.
I suggest watch-ing them, try sending a printing job, then see which one gets updated and read the spitted message.