Printer setup does not work with Gnome (but with Plasma it does)

Hi, I have installed Manjaro Gnome and now I want to set up my network printer (Epson WF-2850). Unfortunately this does not work at all with Gnome, while it works with KDE Plasma (tested with Live USB).

Gnome + Gnome Settings: If the printer is not connected via USB, Gnome Settings will not show the printer at all. Only when I enter the IP address of the printer, there are three new entries: JetDirect-Printer, LPD-Printer and WF-2850. When I select WF-2850, the driver search starts, but it takes a while. The automatically selected driver is "Generic ESC/P Dot Matrix Printer ", with which the printer prints only blank pages.

Gnome + CUPS Webinterface: The printer is displayed only if it is connected via USB (as normal + as FAX). Then I have to manually select “Epson” in the manufacturer list. In the model list my printer is not listed.

I have also tried both variants above with the additionally installed package epson-inkjet-printer-escpr2 from AUR. However, the driver for WF-2860 (not 2850) is automatically selected and only blank pages are printed. A driver for 2850 is not displayed, although the official Epson download page lists the model.

Plasma + Plasma Settings: The network printer is detected. In the manufacturer list there is the preselected category “recommended drivers”, where the drivers “EPSON WF-2850 Series, driverless, cups-filters 1.28.11 (en)” plus the same with Fax is listed (note: On Gnome there is also cups-filters 1.28.11 installed). This driver is also in the “EPSON” category (capitalized, exists in addition to “Epson” category, does not exist on Gnome).

Plasma + CUPS Webinterface: The network printer is detected. The drivers displayed are the same as in the settings plus additionally “IPP Everywhere”.

How can I set up the printer on Gnome? Thank you in advance!

Just got it working. When I tried it again with Manjaro Plasma, I noticed that CUPS uses the protocol dnssd for the printer. I googled this protocol and stumbled upon Avahi. This service is started on Plasma, but not on Gnome.

When I start the service on Gnome, the network printer is found. In Gnome Settings the driverless driver is automatically selected and in CUPS I have the choice between driverless, driverless+fax and IPP Everywhere.

And with this, I can finally print! :partying_face:

What I then tested again in addition: I stopped Avahi, removed the printer from the settings and then connected it again via USB and then tried to add the printer again. The model list does not show me the three drivers from before. They are only available if Avahi is started and I want to add the printer as network printer. (if Avahi is started and I select USB, the drivers are not shown.)

So I have new questions:

  1. Shouldn’t Avahi be in autostart on Gnome, so that network printers can be found? I just tested a fresh Manjaro Gnome in a VM and saw that Avahi is not started there either
  2. What has Avahi to do with the selection of drivers? Why are the compatible drivers only available when Avahi is started and I add the printer as network printer (not USB)?
1 Like

This kind of decisions depend on the DE and the distro. I guess Manjaro Gnome just doesn’t start Avahi by default.

Avahi has nothing to do with drivers. The problem without Avahi, is that your computer system won’t be able to detect network printers on your home network. Your computer system finally detected a printer in your network when Avahi was started.

From :

Avahi is a system which facilitates service discovery on a local network via the mDNS/DNS-SD protocol suite. This enables you to plug your laptop or computer into a network and instantly be able to view other people who you can chat with, find printers to print to or find files being shared.

I have no idea why it isn’t, and that kind of decision isn’t mine to make.

However, is you want to have it start automatically, you just have to enable it:

sudo sytemctl enable --now avahi-daemon.service

Thanks to both of you!

Thanks for this info!
Printing page on the wiki enriched.
For consideration, a suggested change to the gnome profile

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.