Printer setup DELL C1765nfw

Hello everybody,
I am absolutely new to Linux… and to forums. Please forgive me if this question is stupid or pasted wrong.

I have decided to go for Manjaro and to scrap my Windows installation. It works fine so far, but I can’t get to install a printer device. I own a DELL C1765nfw network printer which worked well under Windows. I is connected via LAN switch to the computer.

I have tried multiple tips from the internet, always using the terminal. The commandos used in these tips seem cryptic to me. Can anybody help? Is there a more “noob” (GUI) way for old lads like me?

Thank you,


You have to install this AUR (en) - foo2zjs-nightly
pamac build foo2zjs-nightly

After that, you have to go to http://localhost:631/ and add and select your printer and driver inside administration as described in the last comment there.

Hi bogdancovciu,

Thanks for your help. I have tried both via terminal and “install AUR software”, both times the installation stops with an error message:

==> Processing pre-downloaded ‘getweb’ firmware
make: error while loading shared libraries: cannot open shared object file: No such file or directory

Any idea?
Best, Dan

Better we do it the proper way:
sudo pacman-mirrors -f5 && sudo pacman -Syyu libffi lib32-libffi
sudo pacman -S base-devel --needed
pamac build foo2zjs-nightly

Sorry but again the same error message

==> Processing pre-downloaded ‘getweb’ firmware
make: error while loading shared libraries: cannot open shared object file: No such file or directory

But thank you for the quick reply!!

You did not reboot your system after update ? … I build it on two installs, and i’m sharing just the last part of the build/install

install -d -m 755 /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/bin
install -c -m 755 foo2zjs-loadfw /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/bin
install -d -m 755 /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/lib/udev/rules.d
install -c -m 644 hplj10xx.rules /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/lib/udev/rules.d/71-hplj10xx.rules
install -d -m 755 /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/lib/systemd/system
install -c -m 644 foo2zjs-loadfw@.service /var/tmp/pamac-build-b/foo2zjs-nightly/pkg/foo2zjs-nightly/usr/lib/systemd/system
==> Tidying install...
  -> Removing empty directories...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "foo2zjs-nightly"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Adding install file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: foo2zjs-nightly 20201127-1 (Du 28 nov 2021 12:16:27 +0200)
==> Cleaning up...

Checking keyring...                                                                                                      [1/1]
Checking integrity...                                                                                                    [1/1]
Loading packages files...                                                                                                [1/1]
Checking file conflicts...                                                                                               [1/1]
Checking available disk space...                                                                                         [1/1]
Installing foo2zjs-nightly (20201127-1)...                                                                               [1/1]
> Now reloading udev rules database...
> Now restarting CUPS...

> You need to add your user to the lp group.

> Please refer to the table at
> to choose the appropriate driver for your printer.
Running post-transaction hooks...
Reloading system manager configuration...                                                                                [1/4]
Reloading device manager configuration...                                                                                [2/4]
Arming ConditionNeedsUpdate...                                                                                           [3/4]
Refreshing PackageKit...                                                                                                 [4/4]
Transaction successfully finished.

By the way, if you somehow added sudo before pamac command … don’t do that.