Primus_vk does not properly work & breaks intel-vulkan!

I set up bumblebee on my laptop, and wanted to get it working with vulkan, so I installed primus_vk, primus_vk seems to depend on intel-vulkan in order to run (it requested it when I tried to do pvkrun vkcube), making it a bit odd that it is not listed as a dependency for the primus_vk package.

Anyhow, I installed intel-vulkan, and ran pvkrun vkcube again, this time vkcube ran perfectly fine, this is the output:

PrimusVK: Searching for display GPU:
PrimusVK: 0x5596b307d0d0: 
PrimusVK: 0x5596b319c370: 
PrimusVK: Got integrated gpu!
PrimusVK: Device: Intel(R) UHD Graphics 630 (CFL GT2)
PrimusVK:   Type: 1
PrimusVK: Searching for render GPU:
PrimusVK: 0x5596b307d0d0.
PrimusVK: Got discrete gpu!
PrimusVK: Device: GeForce RTX 2060
PrimusVK:   Type: 2
PrimusVK: fetching dispatch for 0x5596b31ad9e0
PrimusVK: Creating display device finished!: 0
PrimusVK: fetching dispatch for 0x5596b31ac710
PrimusVK: CreateDevice done
PrimusVK: Application requested 3 images.
PrimusVK: Creating Swapchain for size: 500x500
PrimusVK: MinImageCount: 3
PrimusVK: fetching device for: 0x5596b31ac710
PrimusVK: FamilyIndexCount: 0
PrimusVK: Dev: 0x5596b31ad9e0
PrimusVK: Swapchainfunc: 0x7f6b07d7fb40
PrimusVK: >> Swapchain create done 0;0x5596b31a20d0
PrimusVK: Image aquiring: 3
PrimusVK: Selected render mem: 8;7 display: 0
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating image: 500x500
PrimusVK: Creating a Swapchain thread.
PrimusVK: Count: 3

Running vkcube on the intel drivers (without pvkrun) however resulted in this error:

Can't find our preferred formats... Falling back to first exposed format. Rendering may be incorrect.
Segmentation fault (core dumped)

Next I tried to run MPV with Vulkan, whether I use pvkrun or the default intel to run it, I get the same error:

vo/gpu/vulkan/libplacebo: vk->GetPhysicalDeviceSurfaceFormatsKHR(vk->physd, surf, &num, NULL): VK_ERROR_INITIALIZATION_FAILED
vo/gpu/vulkan/libplacebo: Failed picking any valid, renderable surface format!
    vo/gpu: Failed initializing any suitable GPU context!
   cplayer: Error opening/initializing the selected video_out (--vo) device.

Trying to run vulkaninfo nets me roughly the same error (initialization failed), this happens regardless of whether I use pvkrun or not.

Uninstalling primus_vk and restarting the laptop fixes intel-vulkan.

Note: Primus_VK does not inherently break intel-vulkan just by being installed, but only when the nvidia GPU is ‘on’ & the nvidia driver loaded, however I can’t seem to get bbswitch to work to turn the gpu back off after it’s been turned on, this would potentially solve the issue of primus_vk breaking intel-vulkan, however the main issue that primus_vk is not working properly would still remain. I have tried launching programs with the gpu state off through pvkrun, however it just gives me the same results.

Installing primus-vk-git from AUR instead of installing the normal primus_vk from the official repos seems to solve the issue. Performance is a bit shit though (worse than opengl on primusrun)

Edit: While primus-git solves the issue of primus_vk not working right, intel-vulkan is still broken the same way as before.