Prime AMD + Nvidia, DLSS not working

I have a laptop with an AMD 5900QH processor and a dedicated RTX 3070 Max -Q graphics card. Everything works fine but games not detected DLSS. The Nvidia card drivers are 495.44, kernel 5.15.2-2.

inxi -G 
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia v: 495.44
  Device-2: AMD Cezanne driver: amdgpu v: kernel
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo
  Display: x11 server: X. Org driver: loaded: amdgpu,ati,nvidia
  unloaded: modesetting,nouveau resolution: 2560x1440~165Hz
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.2-2-MANJARO LLVM 13.0.0)
  v: 4.6 Mesa 21.2.5
mhwd -li  
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2021.11.04               false            PCI
           video-linux                 2018.05.04                true            PCI

What is the reason DLSS cannot run in games?


Is your nvidia supported by the latest 495 drivers?
Have you tried hybrid-amd-nvidia-470xx-prime ?

Also … just to check:

glxinfo | grep "OpenGL renderer"
DRI_PRIME=1 glxinfo | grep "OpenGL renderer"

You need to force nvapi variable in your Proton startup command with the proper Proton version, and in the config file (I assume this is exactly what you are talking about, right? You Windows games under Proton in Steam?)

Support DLSS in DX11 and DX12 games (guarded by PROTON_ENABLE_NVAPI=1 and dxgi.nvapiHack = False).

Also you need to have the Nvidia video card being the one used to run the game obviously.

You can simply try to modify the Launch Options of the game in Steam by adding PROTON_HIDE_NVIDIA_GPU=0 PROTON_ENABLE_NVAPI=1 %command%


do you suggest uninstalling the drivers for video-hybrid-amd-nvidia-prime and installing hybrid-amd-nvidia-470xx-prime?

glxinfo | grep "OpenGL renderer"

OpenGL renderer string: AMD RENOIR (DRM 3.42.0, 5.15.2-2-MANJARO, LLVM 13.0.0)

DRI_PRIME=1 glxinfo | grep "OpenGL renderer"

libGL error: failed to create dri screen
libGL error: failed to load driver: nouveau
OpenGL renderer string: AMD RENOIR (DRM 3.42.0, 5.15.2-2-MANJARO, LLVM 13.0.0)

Nothing change still can’t use DLSS.

By the way, from what I read, it was supposed DLSS be unlocked awith the 495 drivers. No need to enter any additional commands in Launch Options.

And? Any solution?

If using proprietary drivers the second one should be prime-run instead of DRI_PRIME=1

So I installed hybrid-amd-nvidia-470xx-prime drivers and DLSS still unreachable.

prime-run glxinfo | grep “OpenGL renderer”

give me

OpenGL renderer string: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2

It looks ok.

I try

prime-run %command%

and i get

/usr/bin/prime-run: line 2: fg: no job control

I tried to add a command to the game startup


No result…

There is definitely something wrong with the Prime settings. After checking everything looks as it should, but DLSS doesn’t work anyway. In addition, I found a problem with a badly working external monitor connected via HDMI. Manjaro detects the connected device but does not let go of the signal. I didn’t change anything in the settings, no commands in the console except for checking. This is a clean system with no modifications.

If anyone knows where to report such problems, I will be grateful for the guidance.