Primary screen not working after wake from sleep (only KDE 5.26)

Well I feel like I am fitting right in with this thread.
I have encountered the same issue OP has today.
I use a 1440p 144Hz display over DP and a 1080p 60Hz display over DVI with a 1070 and NVIDIA proprietary drivers.
Since the latest update every time my monitors are going into energy savings mode my 1440p primary monitor is no longer waking up and I am left with my 1080p display taking on the configuration of my primary display (meaning the task bar and background from the primary display). My 1440p monitor is recognized and depending if plasma feels lucky today, I am actually able to finagle my way through the GUI settings menu to reset the configuration (it seems to be a 50/50 chance if that works or not). In any case using xrandr I am able to restore the configuration again. A reboot curiously does not fix the issue, I am forced to manually set up the screens again.
Currently using 5.19.17-1 kernel and KDE 5.26.2-1. Never had any issues previously.
So far I was not able to reproduce the issue when sending my PC to sleep so for me it just seems to be a monitor energy savings issue in KDE.
My current fix for this is just to turn off monitor energy savings mode until this is fixed.

If any of the mods/devs need any diagnostics or want me to test something particular to help fix the issue let me know.


It’s unlikely that KDE devs are reading this forum. I suggest creating a bug report following the instructions given here:

You could also look into the log files to see if you find any error oder warning messages.

Indeed, but I don’t report bugs that need proper repro and proper traces. Manjaro does not provide KDE with debug symbols, KDE devs don’t want useless bug reports, I do the maths for such bug, you get the result.

Traces are only needed in case of crashes. If you have an erroneous behaviour, that you can reliably reproduce, it does make sense to create a bug report. KDE devs usually will look into those and might give additional instructions for you on how to provide more information, if they cannot reproduce it themselves.

Created one. Let’s see how quickly Nate Graham will find a duplicate :smile:


Great. :slight_smile: I did a quick search myself but couldn’t find an existing issue report, but you are right, Nate knows the bug reports inside out and usually closes the duplicates quickly.

Just found this bug report 460341 – On X11, external monitor disabled, setting of external monitor is not remembered. Seems to be directly related to this one. Unfortunately, no solution yet. Deleting ~/.local/share/kscreen still seems to be the only “solution”.

1 Like

Short update:
I just replaced my ancient second display (on HDMI-0) with a newer 34" (on DP-2). Sleep/wake problem is now gone. So the mixture of HDMI and DP seems to confuse current Plasma into writing bogus config files.

You may be onto something, I have DP and HDMI monitors, and I have a similar issue as on this thread, and downgrading KDE fixes it. I should fully upgrade and test latest KDE on Testing branch, confirm I still have the issue, and then use just two HDMI cables and see if it somehow fixes it. It may be a good lead to the issue.

Good thing is that it’s considered as one of the high priority bugs.

… and I can’t do that… I only have one HDMI port on my video card, all others are DP. Latest Plasma 5.26.3 still not fixed. Will go back to LTS 5.24.7.

For the record: Plasma 5.26.4 and this is still unfixed.

With both screens connected over DP it was initially working, but it only lasted maybe 2 reboots and now the problem is back. Still no way to sleep without having to re-configure the screens afterwards. So please ignore my misleading post above. It’s not working.


Have you tried workarounds from the mentioned bug report? Namely this:

Disable kscreen service and using autorandr as autostart script can workaround this


Surely works when kscreen service is disabled. I’ve handled the rearrange monitors by creating a script in /etc/profile.d and using xrandr by now…
Here is my setup:

$ cat /etc/profile.d/
xrandr --output HDMI-0 --mode 1920x1080 --pos 0x360 --output DP-0 --mode 3440x1440 --pos 1920x0 --rate 75 --primary --output DP-3 --mode 1920x1080 --pos 5360x360

To be honest, I’m not really inclined to test the workaround mentioned there. A proper fix would be much appreciated.

But… let’s hope there’s already a fix in the pipeline. Reading this post gives me some hope. Maybe someone can try to compile Plasma using these new sources.


I’m currently trying latest KDE packages available in Manjaro, with the kde-unstable repository, and I think so far the issue is fixed on my side. I’ll have to try to trigger the issue in different ways to confirm it but I did not have the issue “organically” yet, with the system up to date with the kde-unstable packages (Testing branch, but they are also in other branches). I simply added between core and extra the kde-unstable repository in my pacman.conf file

Include = /etc/pacman.d/mirrorlist     

and then I updated the package database and updated the system sudo pacman -Syyu and after a reboot it seems to work for me.

I don’t recommend to do it but for the ones who want to test if the issue is fixed on this current kde-unstable version, you can.

//EDIT: no, it seems it is still the same after all.

1 Like

My way to cope with it till it’s fixed, whenever one screen can not wake from sleep:

  • Manually turn off the screen that can not wake up (e.g with a hardware button)
  • The image should appear on the second screen
  • Open the terminal and type the xrandr command that sets your normal configuration (or fetch it from history, or set an alias to it).
    For example, if I want the screen DP-2 on and eDP-1-1 off:
    $ xrandr --output DP-2 --primary --mode 2560x1440 --rate 165.00 --output eDP-1-1 --off
  • Turn the screen back on
  • Run the command that you typed shortly after you turned on the screen

Might not work if you have no working screens at all when experiencing this issue.

Advantages: no need to touch the display cables, no need to disable kscreen service, no need for startup script
Disadvantages: have to be done each time the screen goes to sleep, still a workaround:(

KDE 27.2 here, issue is not gone on my side…

Hmm, on recent KDE neon User Edition the bug seems to be fixed for me.
However now there is another problem: every time the external screen goes into sleep mode, it wakes up after a few seconds. But that’s a topic for another post…

1 Like

I will need to do more tests, but I think current Testing branch is working for my dual monitor setup, as it should. I’m trying to do real case scenario so I take my time for tests, but the other day my monitors were not messed up after waking up the computer. I cleaned the kscreen local folder though in between when it wasn’t working and when I enabled kscreen2 back to test on current KDE 5.27.3 on Testing branch.

I think I also have this exact issue. Is there anything I can provide information on?
I would need to know the details of how to provide those details if it’s needed.
I came from an older version of manjaro kde/plastma to the latest LTS version.