Primary desktop issue with dual monitor setup

Greetings!

I have been running Manjaro for the last few months (with inconsistent activity, as work and other aspects tend to prioritize Windows usage), however there is an issue I have been unable to nip in the bud, as I am unsure on what is causing it.

To be as specific as possible: occasionally, whenever I boot into Manjaro, my display layout is not as it should be, with my main display showing the secondary display’s content, and with the secondary display having a black background - on which I can still drag windows.

Whenever the issue occurs, if I check the Display Configuration, there is no apparent issue, as it still recognizes which one is my primary display, and which one is the secondary.

To fix this behavior, I have to:

  • Select the secondary monitor, then click on Primary and apply
  • Click back on the primary monitor, and set is as Primary again before applying

Once this is done, it shows the primary desktop on the primary screen, which makes me think there is an occasional issue with loading the correct view, which I am unsure on what it is caused of.

While not a particularly bothersome issue, it is still something I would like to help prevent from occurring, if possible. I had this happening on two fresh installs back from around November and December of last year, which were also of the KDE Plasma environment.

Currently I am running the following:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.18.5-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3800XT 8-Core Processor
Memory: 31,3 GiB of RAM
Graphics Processor: AMD Radeon RX 6900 XT

Please let me know should there be any questions that I can assist with, and thank you kindly, and in advance!

go to system setting/compositor and uncheck enable on startup, click apply, reboot and see if that helps… after that, when you are in your desktop enable it again with this shortcut:
alt+shift+f12