Previews_creator

Hello folks! I just performed a fresh install of Manjaro / Budgie on a ThinkPad today. I immediately noticed a continuous high CPU activity due to a process called “previews_creator.”
/usr/lib/budgie-previews/previews_creator
I have no such process running in the background of my Solus / Budgie machines.

Can anyone help me to identify this application and advise how to kill it?

Thanks in advance!

$ pacman -Fx previews_creator
community/budgie-extras 1.0.2-1
    usr/lib/budgie-previews/previews_creator

So from that package budgie-extras, and specifically the ‘budgie-previews’ part.
But you might want to dig a bit deeper and figure out why.

These might help:

https://bugs.archlinux.org/task/66271

Nice how in that bug report they discount it as a ‘manjaro’ issue when its an Arch package.
And was actually an Ubuntu-Budgie issue in the first place.
Introduced by release 1.0.1 and then fixed in 1.0.2.

Speaking of. If it is the same issue. It should be fixed in 1.0.2 of that package.
Which is current on all branches.

So … @hashbrowns are you up-to-date ?

(oops … edited to point out it is the extras from Ubuntu Budgie that this derives from)

1 Like

Affirmative.
I installed from an ISO which was downloaded today and then performed a full system update.

BTW - does anyone know what this tool does? I’ve temporarily stopped it to see if Budgie crashed and burned, but the only result was a cooler running machine.I’d hate to have to manually stop this process every time that I boot the machine.

You can just uninstall the package.
But … lets be sure here:

pacman -Qs budgie-extras

Yeah, pacman found the package with -Qs, so I performed a -Rs on it and no more “previews_creator” process.

Funny, this is an optional package in the Solus repo, that they do not install by default. They are on v. 1.1.0 vs 1.0.2, here in the community repo.

One side effect that I noticed - I was using a nifty timer applet on the panel called “count down.” After removing the budgie-extras package, this applet was removed from my panel and it is no longed even being offered to me in the Budgie Desktop Settings tool.

I can live with that, until the budgie-extras package is updated.

Thanks for the input everyone …
Cheers!

I gave that command to verify what version you were running.

But given your example … how much do you want to bet that it was that widget causing the issue?

Try reinstalling extras, and dont add (or do remove) that applet. See what happens.

(still technically interested in what version of the package was/is on your system)

OK, so I can’t say as I understand everything that I know about this!

I reinstalled “budgie-extras” (ver. 1.0.2) and rebooted the machine.
Our friend, the “previews_creator” thread is back, running in the background, but it is sitting at 0% CPU use.
I installed the “Count Down” panel applet and the “previews_creator” thread is still at 0% CPU use.
I rebooted the machine and the “previews_creator” thread is still at 0% CPU use.
I put some time on the “Count Down” app and let it count down to zero. At no time did the “previews_creator” thread budge from 0% CPU use.

So, your guess is as good as mine. The only other panel applet that I am using, which does not come preinstalled, is the “Keyboard Layout,” so that I can switch between QWERTY and Workman, but this does not require “budgie-extras” to function.
Frankly, I think that this machine is playing Wack-A-Mole with me. :frowning_face:

I dont think you were up to date.

Here … lets see:

cat /var/log/pacman.log | grep budgie-extras | tail -n12

If I read this correctly, I was on the latest version of “budgie-extras” when I performed the full system upgrade at 2:34pm. It was only later in the afternoon that I added the panel app and noticed the high CPU usage, but I still can’t put my finger on what triggered the event. I just happened to notice that the exhaust cooling air was unusually hot, when the machine should have been idling.

And, I did definitely perform a reboot after doing the system upgrade. In fact, I rebooted the machine a couple of times before removing “budgie-extras” to see if that would make a difference … which it didn’t.

    [xxxxx@copernicus ~]$ cat /var/log/pacman.log | grep budgie-extras | tail -n12
    [2020-10-06T14:34:54-0500] [ALPM] upgraded budgie-extras (1.0.1-1 -> 1.0.2-1)
    [2020-10-06T17:37:36-0500] [PACMAN] Running 'pacman -Rs budgie-extras'
    [2020-10-06T17:38:03-0500] [ALPM] removed budgie-extras (1.0.2-1)
    [2020-10-06T18:31:14-0500] [PACMAN] Running 'pacman -S budgie-extras'
    [2020-10-06T18:31:27-0500] [ALPM] installed budgie-extras (1.0.2-1)

It says right there that minutes before you removed it you updated it to the correct version.
EDIT - actually no … looks like a few hours … but still same day.
(as in you hadnt restarted with 1.0.2 … as in your problem was the out of date version/system)
[I guess its possible that the remove cleaned out some old configs or something … but its doubtful given other clean upgrades, and that removes wont touch your home even if there was special configs]

EDIT Cont. - Hm. That makes it a bit more perplexing. but maybe restart is the thing here?
Either way it seems to verify that the current version works.
The only query is how exactly your steps worked out.

Well, the current version is working … currently. With any luck, it will keep working.

Sure. hurrah.
Any landing is a good landing as those air people say.
Cheers :slight_smile:

1 Like