PPPoE connection not working | Raspberry Pi 4 XFCE

Since I would like to use Manjaro XFCE on my Raspberry Pi 4 Model B Rev 1.2 instead of Raspberry Pi OS as I did in the past, I flashed the new system with the Raspberry Pi Imager.
When I booted into the desktop, I found out that after creating a new PPPoE connection with nm-connection-editor, the connection does not work; it connects to it for a few seconds and then it disconnects, so I can’t connect to the internet through cable. I do not have a router. I was able tho to connect to a mobile hotspot, from which I am writing now.
On Raspberry Pi OS, the PPPoE connection worked and I don’t know what I should do/try to find out why this problem occurs on Manjaro ARM.


The rp-pppoe package is already installed by me, alonside with net-tools package.
On my x86 computer, the package is not installed, but the PPPoE connection works. I use Manjaro XFCE there as well.

After I talked with the internet provider, with their help and tinkering on their side, I was able to fix the problem.
But I still have one question: how is it that on my x86 computer where the rp-pppoe package is not installed, the pppoe connection works?
In any case, thank you very much for your response because I just tried removing that package to see if the connection works without it here as well and it does not.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.