Powerline not working in konsole

i just configured manjaro’s default konsole theme to breeze dark and now powerline seems to be not working!?

looks like i mistakenly changed this shell from bash to zsh, don’t know what happened when i changed the global theme, auto completion in konsole is also not working, please help!!! im confused, don’t know what to do, please get powerline working for me :frowning:

Hi @Mmshukla21,

What happens when you start zsh manually from the terminal?


it works but when i try to restart konsole again the next time it goes back to the same bash shell again with the breath theme

That is what I expected, yes. Now:

  1. Open Konsole.
  2. Go to SettingsConfigure Konsole at the bottom there.
  3. Click on Profiles.

And tell me if you created a custom profile or not?

1 Like


Type this:

sudo chsh -s /bin/zsh your_user_name

Then log out and log back in, it will switch your default shell from bash to zsh


This is equivalent to

chsh -s /bin/zsh

as a non-root user. No root user needed.

Cool, didn’t know about that

i haven’t created any custom profile

thanks it worked :slight_smile:


Now, to change it, run the command @rcht gave, in the terminal:

chsh -s /bin/zsh

And log out and back in, or just reboot after. Should, theoretically work.

1 Like

yes it worked thnx @oguere he was right, it was just a single command!!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.