Powerline in manjaro-zsh-config

Manjaro-zsh-config gained support for powerline prompt. It is automatically enabled for new user accounts, disabled for TTY and root user. If you want to enable it in your older installation, set the environment variable

 USE_POWERLINE="true"

Note the quotes, they are needed. Note that you also need to use a suiteble font, like one of the nerdfonts that are pulled as a dependency.

4 Likes

Meaning nerd-fonts-noto-sans-mono is pulled in as the default Nerd Font as a companion to our default Noto Sans fonts used. However…

Powerlevel10k doesn’t require custom fonts but can take advantage of them if they are available. It works well with Nerd Fonts, Source Code Pro, Font Awesome, Powerline, and even the default system fonts. The full choice of style options is available only when using Nerd Fonts.

Recommended font : Meslo Nerd Font patched for Powerlevel10k.

ttf-meslo-nerd-font-powerlevel10k is an optional dependency of zsh-theme-powerlevel10k, I also recommend it for the best experience.

5 Likes

Looks a bit different on my Terminal
Imgur

How can I enable the time like @Yochanan has on the right side?

@Yochanan has his own configuration. If you want to have some other configuration, comment out the prompt section of the zshrc and configure p10k manually.

 p10k configure

If you want to disable it for TTY, check how the default prompt does it and adapt that.

1 Like

You need to use a different theme for that.
Fe. I prefer to use oh-my-zsh which has many to choose from.

1 Like

I know about that, have it for the root user @TriMoon

p10k is actually super configurable

This one looks good :ok_hand:t3::ok_hand:t3::ok_hand:t3:

Is zsh now the default CLI shell on all main editions (and not just on GNOME)? It has been a long time since I checked ISO images.

No, only gnome and many community editions for now. @philm and @cscs don’t like zsh.