Powerlevel10k somehow not working

a month or two ago there was a stable branch update that added powerlevel10k to one of my manjaro gnome installations but not the other:

pamac tells me zsh-theme-powerlevel10k is installed on both systems, but if I try to check if it is running on the system from the first screenshot:

~ >>> p10k configure                                                           
zsh: command not found: p10k

I tried reinstalling the package but it does not fix the issue.

There are a few other packages you could and should install to get the default Manjaro prompt in zsh

  • manjaro-zsh-config
  • zsh-autosuggestions
  • zsh-completions
  • zsh-history-substring-search
  • zsh-syntax-highlighting
  • zsh-theme-powerlevel10k

Install the ones that are not installed and post the result :slightly_smiling_face:

try and copy /etc/skel/.zshrc to home.
the .zshrc in home should look like this:

# Use powerline
# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt
1 Like

just checked, all of those have been installed.

that worked! Thanks!
I wonder why p10k configs never carried over in the first place.

I think you installed Manjaro when the p10k prompt was not used by default, so when the p10k was included through an update, it did not overwrite your user zsh config (~/.zshrc).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.