Power shutdown while updating, trying to fix it made things worse, grub doesn't find Manjaro anymore

Hey everyone, I’m not the brightest star in Linux stuff, but here we go.
I was updating Manjaro Xfce, and while I was doing it, the impeccable timing of a power shutdown, my PC zero’d. After turning it up again, the /boot/vmlinuz-5.14-x86_64 not found error was found.
I got my livedisk pendrive with ventoy and a Manjaro xfce went in chroot to try to fix it. Till then, everything was working kinda ok, closed the Pendrive live disk, went in manjaro again and it didn’t worked, then I tried again. This time I followed this tutorial: [HowTo] Recovering from an interrupted update/upgrade
Which is a great tutorial, but the thing is, after I did the update-grub on my terminal, and went into Manjaro and well, nothing was there, windows from my other HD, and Manjaro.

After trying to fix it, i downloaded grub again, reinstalled it, and it still didn’t find both systems.

Hi there,

We might need more information.

Possibly beginning with something like


At least. Maybe inxi -Fazy would also be helpful.

We really dont know what exactly you performed, or what your current error is.

But to begin with

Is indicative of at least one or two things fundamentally wrong besides the interrupted upgrade.
Kernel 5.14 has been EOL (end of life, dead actually) for … years I think?

lsblk output

loop0        7:0    0 156.4M  1 loop /run/miso/sfs/livefs
loop1        7:1    0   1.1G  1 loop /run/miso/sfs/mhwdfs
loop2        7:2    0   1.5G  1 loop /run/miso/sfs/desktopfs
loop3        7:3    0 767.4M  1 loop /run/miso/sfs/rootfs
sda          8:0    0 465.8G  0 disk 
├─sda1       8:1    0   300M  0 part 
├─sda2       8:2    0 448.4G  0 part 
└─sda3       8:3    0  17.1G  0 part 
sdb          8:16   0 465.8G  0 disk 
├─sdb1       8:17   0    16M  0 part 
└─sdb2       8:18   0 465.7G  0 part 
sdc          8:32   1   7.5G  0 disk 
├─sdc1       8:33   1   7.5G  0 part 
│ └─ventoy 254:0    0   3.5G  1 dm   /run/miso/bootmnt
└─sdc2       8:34   1    32M  0 part

inxi -Fazy output

  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_XFCE_2313 quiet
    systemd.show_status=1 splash apparmor=1 security=apparmor driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: A320M-HDV R4.0 serial: <superuser required>
    UEFI: American Megatrends v: P4.00 date: 07/16/2020
  Info: model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64 type: MT MCP
    arch: Zen/Zen+ note: check gen: 1 level: v3 note: check built: 2019
    process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
    microcode: 0x8108109
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1773 high: 2300 min/max: 1600/3500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1600 2: 1600
    3: 2300 4: 1595 bogomips: 27959
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
    driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
    built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 4 link-max: lanes: 8
    ports: active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0
    chip-ID: 1002:699f class-ID: 0300 temp: 38.0 C
  Display: x11 server: X.org v: compositor: xfwm v: 4.18.0 driver:
    X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: BenQ G610HDAL serial: <filter>
    built: 2011 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1366x768 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 550 / 550 Series
    (radeonsi polaris12 LLVM 16.0.6 DRM 3.54 6.6.10-1-MANJARO)
    device-ID: 1002:699f memory: 3.91 GiB unified: no
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4 link-max:
    lanes: 8 bus-ID: 01:00.1 chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Device-3: Soundprese HD-II driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:4
    chip-ID: 18ee:52f8 class-ID: 0300
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 939.04 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BC142
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: JC4B scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500LM034-2GH17A
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: LXM4 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 model: USB DISK 2.0 size: 7.52 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s lanes: 1
    mode: 2.0 tech: N/A serial: <filter> fw-rev: PMAP scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 42.5 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (rpm): N/A
  Processes: 243 Uptime: 5m wakeups: 0 Memory: total: 16 GiB
  available: 15.55 GiB used: 2.47 GiB (15.9%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1159 libs: 321 tools: pamac pm: flatpak pkgs: 0
  Shell: Bash v: 5.2.21 running-in: xfce4-terminal inxi: 3.3.31

Also, sorry, ive made a mistake, i didnt put the right kernel in the text, it was a mistake from my part. It wasn`t 5.14, a newer one basically, i put it there as a illustration and forgot to explain.

Sorry I left this unanswered by accident.

Did you make any progress?

The new inxi output still looks a bit odd

From the lsblk output it appears maybe these are what you are after?