Power Saving options keeps resetting to default

Hi all, on my MatebookD ryzen i no longer can adjust power saving option in KDE control panel.
Options like “stop chargin after a certain percentage” or “start charging once only below %” keeps resetting instantly.
They worked when i did a clean install of manjaro.

Could someone help me? thanks

I wonder if your system needs a battery system reset? The way to do this is to turn off the power saving controller. Shutdown. Charge the laptop to full 100%. Reboot, turn off power control features, use the laptop unplugged until it shuts down by itself due to lack of power. Recharge it to 100%. That will reconfigure the battery controller charging.

(PS: I would not bother with trying to over-think the charge controller system with those options. Just charge to full when needed and let the hardware charge controller do its thing.).

1 Like

I’ll try to download the latest manjaro iso and enter the live environment to see if it works.
The problem now is i set a value i want, i click apply, type admin password, change page, reload page and the value is resetted to 50% (default was 70!)

It seems i definitively lost this option.
It used to work when i had a dual boot configuration, with the huawei driver installed in windows. (or in some hidden place of the hard disk).
It worked perfectly…

I probably found a solution: according to this guide , the culprit is the huawei-wmi driver reporting incorrect values.

I followed these steps and now it seems working again!

 Battery protection

The Huawei WMI driver `v3.3` to expose battery protection thresholds was merged into kernel `5.5` [[2]](https://github.com/aymanbagabas/Huawei-WMI). There is an issue[[3]](https://github.com/nekr0z/matebook-applet/issues/22) where the hardware reports incorrect values for the charge thresholds, preventing battery protection from working. The maintainer of the driver has stated this should be fixed in userspace[[4]](https://github.com/aymanbagabas/Huawei-WMI/issues/36#issuecomment-657127421).

A temporary fix is to write some sane values to the file:

# tee /sys/devices/platform/huawei-wmi/charge_control_thresholds <<< '40 70'

This will enable battery protection (in this case, the device will stop charging at 70%). In order for [matebook-applet](https://aur.archlinux.org/packages/matebook-applet/)<small>AUR</small> to run without superuser rights, add your user to the `huawei-wmi` group since the thresholds are still read-only to non-root.

usermod -a -G huawei-wmi $USER

Alternatively, [huawei-wmi](https://aur.archlinux.org/packages/huawei-wmi/)<small>AUR</small> will set the group write privileges. This will also take care of the thresholds resetting randomly upon reboot by automatically reinstating the battery charge-thresholds. For more information, see [this guide](https://github.com/nekr0z/linux-on-huawei-matebook-13-2019).