Power management settings causing the phone to lock itself every time the screen is touched


Since the last stable update (2021-03-20), I encountered a pretty frustrating issue on my PinePhone (Manjaro Edition running plasma beta2, updated).

After booting, the phone works fine as usual but after around a minute it freezes, and shows the lockscreen. After the pin is entered and the phone unlocked, the phone freezes again after touching the screen or after a short while making the touch screen basically unusable (the phone works fine over ssh).

I tried the latest beta3 release, it worked fine while configuring it until the issue reappeared. Same thing with today’s build (20210323), so I must be doing something to trigger it.

I spent the last few days trying to find what caused this bug and I managed to find a way to replicate it:

  1. Install a fresh OS (20210323 for example), select the timezone, connect to the Wifi and set the user account.
  2. Unlock the phone, long press the power button and restart the phone. (For some reason, I get a blurry and low resolution UI at the first start, rebooting fixes it).
  3. Unlock the phone, go to Settings > Screen and then set ‘Lock Screen and Sleep’ to 5 min and ‘Turn off the Screen’ to 5 min.
  4. Quit and reboot.
  5. Make sure that the settings are set at the next reboot and you should experience the bug after a few minutes.

I’m not sure if selecting another duration causes the same issue, but for the moment I’m running the OS with the default and the bug didn’t show up yet.


Having a similar issue on PinePhone Manjaro Phosh Beta 12.

But my phone freezes after one minute and nothing happens anymore, screen stays on, ssh does not work anymore… looks like the whole system is frozen.

Tried rebooting several times to search for fixes, but one minute is not much time find find bugs.
The last thing I did before this happened was making a hotspot… but its already disabled… any hints very welcome, the phone is my daily driver and it drives me nuts…

did you use the mobian script? If so perhaps it is not compatible with manjaro?

no mobian script used on this…