Power management issues : tlp config files seems to be overitten all the time


I am new to Manjaro Linux - actually I used to use Linux distros for several years in the past, mostly Debian and RH based and recently decided to give Manjaro a try ). I am running Manjaro in a pretty powerful business laptop : Lenovo p15 gen 2 equipped with NVMe’s, 11th gen i7 and 32 GB of ram. My system is ( usually up to date ), updated using yay and pacman. For about a month I am trying to set tlp and power management tools such as slimbook, threshy etc.
Here are my main issues - actually if fix them my laptop will be a 101% successful setup , but the powermanagement issue are currently pretty annoying… :

  • When on battery the system boots normally till GDM level, I login but never procceds to load desktop on main screen , it actually loads only one screen on an external. I am pretty sure that GPU governors cause the issue : Some times I’ve got an error on journalctl -u tlp.service like : not suported gpu frequency. That makes sense because the available gpu freq for intel graphics are between : 400-1150 according to tlp-stat -g and my configuration is 300 INTEL_GPU_MIN_FREQ_ON_AC=300.

  • And I think that this is the root cause of all my problems : TLP CONFIG FILE SEEMS TO BE OVERWRITTEN ALL THE TIME. I am trying to edit some changes like changing min gpu frequency, commenting out cpu freq min/max values and live just with cpu min/max performance as I use intel_pstate driver and tlp recommends that, also experiment with other values for tweaking my laptops battery performance but after some suspends the file is overwritten to default values.

I tried to disable slimbook, but not fixed. Currently its disabled and I will reutilize it by the time I fix the previous issues.

Just for your info : I am using pipewire instead of pulseaudio/jack, I am using graphics hybrid mode using Manjaro HW detection, threshy battery charging tool works as expected.

Any ideas ? Thanks !!!

I don’t know the other tool you mentioned but having more than one power management program running is asking for errors.

You should focus on one, set it up perfectly and then check (1) if you actually need another one and (2) if they interfere.

Hello Mithrial , thanks for the fast reply. Ok , according to the documentation slimbook does not work against tlp but it integrates and utilizes it. But thats not the issue, currently its disabled.

I forgot to mention that when the laptop is connected to ac, it works great. I have also tried to apply the changes using tlpui and also restarting the service , disabling it and enabling again. The configuration remains after service restarts and re-enabling, even after some restarts or suspend/wake-ups.

Slimbook Battery is what is changing your TLP configuration. Either use it and let it manage it, or remove it and set the configuration yourself manually or with tlpui.

Maybe you are editing the wrong file, eg. a runtime-only config instead of a more permanent one?
Please post the absolute full-path of that config file, so people will knkow you are editing the correct one.

Disclaimer: I don’t use the mentioned service/app

Thanks for the replies, I edit this file : /etc/tlp.conf .

EDIT : I totally removed slimbookbattery ( yay -R slimbookbattery ) and I will update if the issue still persists.

@Yochanan just keep in mind that I noticed changes on on /etc/tlp.conf after shuting down slimbook. We will see…

Hello again, its pretty safe to tell that after getting rid of slimbook battery tlp works as I was expecting. Thanks !

Then i suggest to mark the answer Power management issues : tlp config files seems to be overitten all the time - #4 by Yochanan as the solution as a thanks :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.