Power button not working


My power button (on the desktop, not the physical button) does not work in Plasma desktop anymore. When I push it nothing happens. Switch user and sign out still works but look strange, with no theme, just black background.

I’m pretty sure that this happened after the second last update. I was waiting for the last update to possibly fix it but it’s still the same.

As of now I am getting around the issue by typing “systemctl reboot” in console, but would like to get the buttons back, even if it’s only a minor annoyance.

I would appreciate any solutions or ideas. Thanks in advance!

You have a “power button” on the desktop? If so you added it. Is it a widget, like the Lock/Logout widget? Most people put those in the system tray or a panel rather than the desktop itself. If it is a widget, right click and check the configuration settings for the widget and set as you desire. If that doesn’t help, then delete the widget from the desktop or panel and then re-add the widget. If it is a widget other than Lock/Logout - check with the widget developer and see if it is still supported. If my assumption about the “power button” being a widget is wrong, please give us a little more information to work with.

Hi, thank you for your reply!

I’m sorry if my description was unclear. What I mean is the overall power/reboot/shutdown function on the desktop. I do have extra widgets added for this purpose and they do not work either but neither does the power button in the start menu, the standard one that comes with the desktop. All my other widgets work fine, as well as all other links in the start menu.

Edit: I’ll add pic here to make it more understandable. My system is in Swedish but it is the last two buttons that don’t work at all (restart and shut down) as well as log out. Switch user and lock both work but look strange with all black background, not themed as they should be.


Please provide some information.

Hi again.

The problem in short is that power-related buttons on the desktop are unresponsive.

The issue started after the second last update. I have tried systemctl reboot and it works so the problem seems to be at the desktop level.

I’m currently using the latest kernel 5.15.7-1 and have also tried LTS 5.10.84-1. No difference there concerning the problem.

  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=94747e2f-2593-4eee-bde0-c0b03c16f9cd rw quiet
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-E GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1201
    date: 12/07/2018
  Message: No system battery data found. Is one present?
  RAM: total: 31.34 GiB used: 2.41 GiB (7.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1927 high: 2491 min/max: 2200/3700 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2491 2: 2195
    3: 1717 4: 1765 5: 1763 6: 1770 7: 1709 8: 1718 9: 2094 10: 1902 11: 1944
    12: 2065 13: 1886 14: 1966 15: 1886 16: 1972 bogomips: 118224
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
    cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
    fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm
    mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
    nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
    pse36 rapl rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap
    smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock
    syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel bus-ID: 0c:00.0 chip-ID: 1002:731f class-ID: 0300
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
    s-diag: 777mm (30.6")
  Monitor-1: DisplayPort-1 res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
    bus-ID: 0c:00.1 chip-ID: 1002:ab38 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0e:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 chip-ID: 0951:16a4
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    port: e000 bus-ID: 04:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus-ID: 05:00.0
    chip-ID: 8086:2526 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-3: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad
    bus-ID: 3-2:3 chip-ID: 045e:0719 class-ID: ff00 serial: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> scope: global
  IP v6: <filter> scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-9:4 chip-ID: 8087:0025 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 5.69 TiB used: 3.63 TiB (63.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS100T3X0C-00SJG0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 111110WD temp: 43.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS250G1B0A-00H9H0 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 10WD
    scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD4005FZBX-00K5WB0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 434.92 GiB size: 427.09 GiB (98.20%)
    used: 167.06 GiB (39.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 94747e2f-2593-4eee-bde0-c0b03c16f9cd
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 264 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: ESP-LINUX uuid: DB0E-176D
  ID-3: /run/media/nbadmin/BigBoy raw-size: 3.64 TiB
    size: 3.64 TiB (100.00%) used: 3.47 TiB (95.4%) fs: ntfs dev: /dev/sdc2
    maj-min: 8:34 label: BigBoy uuid: 7A6C87A76C875CAF
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
    uuid: 0513d6f1-b090-4df4-9bb5-f73559b178c2
  ID-1: /dev/nvme0n1p4 maj-min: 259:4 size: 488.28 GiB fs: ntfs
    label: Speedboy uuid: 0DA4F7105EFE3503
  ID-2: /dev/sda1 maj-min: 8:1 size: 529 MiB fs: ntfs label: Recovery
    uuid: 14BC932EBC93097E
  ID-3: /dev/sda2 maj-min: 8:2 size: 100 MiB fs: vfat label: N/A
    uuid: AA94-596A
  ID-4: /dev/sda3 maj-min: 8:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-5: /dev/sda4 maj-min: 8:4 size: 686.74 GiB fs: ntfs label: NB-Win
    uuid: 060EB5ED0EB5D5C1
  ID-6: /dev/sda5 maj-min: 8:5 size: 599 MiB fs: vfat label: N/A
    uuid: 1A49-437C
  ID-7: /dev/sda6 maj-min: 8:6 size: 237.7 GiB fs: ext4 label: N/A
    uuid: 453611e0-3fec-400d-aff1-649b5ee9067c
  ID-8: /dev/sda7 maj-min: 8:7 size: 5.86 GiB fs: swap label: N/A
    uuid: 795274d4-9cd1-4b49-ac26-ec493cad2df4
  ID-9: /dev/sdb1 maj-min: 8:17 size: 232.88 GiB fs: ntfs label: Extra
    uuid: 6CD68AAC37882E12
  ID-10: /dev/sdc1 maj-min: 8:33 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Corsair STRAFE RGB Gaming Keyboard
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 1b1c:1b20 class-ID: 0300
    serial: <filter>
  Device-2: 1-8:3 info: ASUSTek AURA MOTHERBOARD type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 0b05:18a3 class-ID: 0300 serial: <filter>
  Device-3: 1-9:4 info: Intel Wireless-AC 9260 Bluetooth Adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:0025 class-ID: e001
  Device-4: 1-10:5 info: Corsair Lighting Node Pro type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA
    chip-ID: 1b1c:0c0b class-ID: 0300 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Kingston HyperX 7.1 Audio type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0951:16a4 class-ID: 0300
    serial: <filter>
  Device-2: 3-2:3 info: Microsoft Xbox 360 Wireless Adapter type: WiFi
    driver: xpad interfaces: 8 rev: 2.0 speed: 12 Mb/s power: 260mA
    chip-ID: 045e:0719 class-ID: ff00 serial: <filter>
  Device-3: 3-3:4 info: ASUSTek ROG PUGIO II type: HID,Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 0b05:1908 class-ID: 0300
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 50.0 C
    mem: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1169
  Processes: 324 Uptime: 22m wakeups: 0 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1451 pacman: 1432 lib: 392
  flatpak: 14 snap: 5 Shell: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

And to double-check …
System Settings > Power Management > Energy Saving

  • :heavy_check_mark: Button Events Handling
  • When power Button is Pressed > ?
    (For me it is: “Prompt log out dialog”)


You have BIOS update available: https://rog.asus.com/motherboards/rog-strix/rog-strix-b450-e-gaming-model/helpdesk_bios

Hi, thank you for your input :slight_smile:

Checked settings, mine looks the same.

Regarding the bios update, this is complicated with these ASUS boards as they use the same bios for different generations. The version I have is the latest one for Zen+ boards, the later ones are for Zen2 and Zen3. I made the mistake once of upgrading to a Zen2 bios. It worked but messed up a lot of things. I had to go through a painful process of rolling back the bios, which the regular update does not allow. So, after reading about it and seeing people recommend not to update, I chose to stay with this one.

Do you think it could be connected to the issues I’m having?

When you logout and get to SDDM, does the power off or reboot buttons work from there? Lastly, are you using a global theme other than Breeze or Breath? If so, try going to a vanilla Breeze theme and see if you have the same problems. I’m not smart enough to know if your bios might be the issue, but since systemctl reboot works, it seems like that would be less likely.

One more quickie. If your SDDM theme has changed, go to settings → startup and shutdown → Login screen (SDDM) → click on the behavior button on the bottom → the halt and reboot commands should be visible and pointing to systemctl shutdown and systemctl reboot.

I’m running out of ideas…

1 Like

I can’t log out, poweroff, restart and logout are all unresponsive, only “switch user” and “lock” work and they don’t provide any power-related buttons.

I was using a custom SDDM theme but tried switching to both vanilla Breeze and Breath with no result. Global theme is already just ordinary Breath, but I will try switching and re-applying, maybe it helps?

Under SDDM - behaviour - halt and reboot everything looks fine:

/usr/bin/systemctl reboot
/usr/bin/systemctl poweroff

I suppose last chance is to try to switch global theme, but it seems doubtful.

What I find strange is that “switch user” and “lock” are working but not the other 3 alternatives. Do you know if these are connected to different things? Does SDDM handle the 3 options that do not work but not the other 2? Then maybe something with SDDM is broken? I never really understood the different login features available in Linux.

Edit: I checked my logs for errors and found the following which maybe be relevant:

org.kde.kdeconnect ICE default IO error handler doing an exit(), pid = 6674, errno = 2

systemd plasma-kactivitymanagerd.service: Failed with result ‘exit-code’

Edit 2: Never mind the above errors, unable to reproduce them so they seem to have been connected to that particular boot.

I also solved the issue with the buttons after a day of troubleshooting. The issue was quite ridiculous and not at all as deep as I had assumed. I realized that it had nothing to do with SDDM as both switch user and lock worked fine and at least “switch user” seems to drop me to SDDM. Restoring global theme also made the “switch user screen” look like it used to. Then I remembered that the restart and poweroff options do not put you in SDDM but rather some form of graphical overlay on the desktop.

For future reference this is what I did:

Settings - Startup and Shutdown - Desktop sessions - deselect “confirm logout” and “offer shutdown options” - apply. Now the buttons work. Next session after restart simply apply them again and the overlay works again.