POVRAY: Compiling on manjaro?

Hi folks
I’m trying to compile the povray raytracer on manjaro, but having difficulties. Is there anyone out there that can give a few tips? I run machines with debian and manjaro. The povray is easily installed from source on debian, but I’m having trouble resolving dependency issues in the arch repos. Any help is greatly apprecated!

EDIT: Specifically, I’m stalled deep, deep, deep in a tragic descent into dependecy hell by povray’s requirement of a libjpeg with ‘jpeg_std_error’. Povray stumbles over this in the configure phase.

Why are you trying to compile it? It’s in the repository. :arrow_down:

sudo pacman -S povray

I need to modify the source

Already tried:

pamac install povray

povray [Instalado] 2: community Script based raytracer for creating 3D graphics

T+ = So long

Why? Modify what? It would be better to edit the PKGBUILD.

Package comes directly from arch, take a look at its PKGBUILD:

How are you trying to do it?

the PKGBUILD, which is used to build the program from source to create the Arch package
is here:

svntogit-community/PKGBUILD at packages/povray · archlinux/svntogit-community · GitHub

you could do your needed modifications by modifying that script

Thanks for your reply.

How are you trying to do it?

I’m trying to compile the povray source like this:

  1. Download source - OK
  2. Run prebuild.sh - OK
  3. Run configure - FAILS ON: no ‘jpeg_std_error’ in jpeg library
  4. Run make - not there yet
  5. Run sudo make install - not there yet

the PKGBUILD, which is used to build the program from source to create the Arch package is here:

I’m new to the arch world - truth be told, I don’t know how to build the package. I’ll try to find some docs on this

keyword is “makepkg”

The PKGBUILD is the description of the process you are trying to do “manually”
I’d first try to build it “as is” - to make sure it works for you
then try to incorporate your modifications.

The script as it is should take care of the dependencies - install them.
Don’t know whether your modifications will require additional dependencies.

You don’t need to compile anything, povray has it in the official manjaro repository

T+ = So long

he want’s to modify the source prior to building

Right. If he’d actually tell us what he wants to do, then maybe we could help. Ahem @MichaelAfSjaelland

Modify the source code, but if so, what do I ask for?

sudo pacman -S povray


T+ = So long

yes - but:
he want’s to modify the source this package is built from
build a modified package from it
installing the unmodified package … will not do :wink:
not for him, anyways …


Well, I think I did say what I actually wanted to do, namely, compile povray from source. If I wanted to download the package and run a stock povray I would have done that.

git clone -b packages/povray --single-branch https://github.com/archlinux/svntogit-community.git povray
cd povray/trunk/
makepkg -o

Do whatever the hell you want with the source files in src/…

makepkg -ei
1 Like

Ok thanks, I’m getting it it by bit. I renamed the arch_pov.sh script to PKGMAN and said:


The script failed with error (last 3 lines):

==> Retrieving sources…
→ Found povray-
==> ERROR: povray-openexr3.patch was not found in the build directory and is not a URL.

on this line:


Sorry about the weird formatting

The PKGBUILD for this standard package seems a little different than what I normally deal with - packages from the AUR
I usually do not recompile packages which are … available as a precompiled package.

The referenced patch, the patch you need/the PKGBUILD needs
is in the same diretory as the PKGBUILD:

svntogit-community/trunk at packages/povray · archlinux/svntogit-community · GitHub

get it from there and put it with the PKGBUILD

Thanks Moson, I tried what you said. ./configure is still failing with:

checking whether to use the JPEG library... yes
checking for library containing jpeg_std_error... no
configure: error: cannot find a suitable JPEG library

but now I’m over the openexr patch thing, thanks for that. I’ve been looking for that elusive jpeg library that has a ‘jpeg_std_error’, but maybe I’m barking up the wrong tree. Any ideas?

Thanks, I hadn’t seen that