Potential hplip - hp-plugin discrepancy in latest release (?)

Team Manjaro,

I think there might be some discrepancies between hplip and hp-plugins. I am not tech savvy enough to troubleshoot. Ended up loading a different distro last night to get some documents scanned.

I should have copied/pasted the error - signature key was wrong. Files did not match. I could not download the driver as packages were not corresponding. I jumped on a backup distro and hplip worked flawlessly, downloaded the correct driver for my all in 1.


PS: I removed, purged hplip…reinstalled. Same error. I obviously do not scan much. My printer printed w/out difficulty…it only was an issue when I had to go through the hplip setup to download the full driver.

Same problem - new install (switched from Ubuntu!) HP Laser Jet Pro MFP M277 dw - cannot install HP Plugin to use scanning function of MFP - signature key was wrong. Files did not match. Scan a lot of photographs so really need this function or will have to switch back to Ubuntu.