Possible problems with late versions of KDE

I recently did a clean install of Manjaro KDE into a new NVME drive (linux-510). Since installing, I’ve been having a few issues which have been very frustrating to deal with. Booting up using an older kernel (linux-54) did not fix the issues, so I can only assume the issues are related to any KDE updates that have rolled out since the last time I did a clean install, which was in mid-April. Is there some way I can install an earlier version of KDE so I can avoid these issues? My original drive has been wiped, so I can’t clone it. And if anyone is curious, the two main issues I have been experiencing include:

  • Plank: When an active window is open in the bottom portion of the screen, the plank dock will appear when I mouse toward the bottom of the screen like normal. But when I click on an icon, the icon dims as if I had clicked it, but nothing happens. This behavior is inconsistent, because if I click and drag icons with an active window open behind the dock, I can still rearrange the icon order. Also, holding right mouse button then left clicking will successfully left click the item on the dock, and holding left mouse button then right clicking will execute a right click. This error stops happening when I do not use the hide dock feature, making me believe it may have something to do with the compositor.

  • Keyboard Shortcuts: Ctrl+C will copy text and store it in the clipboard, but Ctrl+V will not paste it anywhere, except in rare cases where it will paste the text, but only a few times before the keyboard shortcut stops working. Middle mouse button will paste the text successfully every time.

These problems are making me want to quit and install XFCE again, because I feel like I’m only going to discover more problems as time goes on. If you read the issues I am having and can offer other fixes, I would appreciate that. Thanks for your time.

You don’t, you have the KDE version Manjaro delivers.

Can’t comment on your issues, everything works for me.

When was your install? My last install that worked was in mid April like I said, and this install was finished yesterday.

It’s an old install, from last year.

Does the issue occur in a pure unmodified Manjaro KDE? Maybe what you install creates conflicts?

It shouldn’t be a conflict because I didn’t install anything I didn’t have in my last drive, unless some of the packages have changed. I can check if the issues happen on the live USB but that’ll have to wait until tomorrow because I also wiped the USB stick and I’m too tired to go back to my PC (on my phone now)

Yep, I also did a fresh install last month. Everything’s working fine on KDE side.
@waffle Maybe, create a new user to see if the issues persist.:wink:

1 Like

So you actually modified the system and installed stuff, therefore it could be a conflict with what you install.

It technically could be, but I’m saying it’s unlikely because all the packages I installed this time, were all installed in the last Manjaro instance I had as well.

There are things that still could be different, like new default settings, or your own settings customization in the apps you install, as well as new configuration files in the system you might never have merged before (.pacnew files). For now this is the most probable lead for your issues to me.

I created a new user and all of the problems have disappeared. Thank you for your help! @omano you too! I guess it was something I did when I was going through the settings.

1 Like

About Plank, maybe Dash to Dock would be a better option, as it’s tailored for KDE.

the GNOME thing?

1 Like

Oooops, was not well awaken…

I thought of Latte Dock…

I tried latte for a bit but it felt laggy compared to plank. The animations on it felt more like artificial latency than a smooth experience.

I have this old install from 2019 and I don’t have the keyboard problem you said,Plank I can’t speak because I use latte-dock.

Do you have the clipboard applet disabled or something? maybe that the culprit but i can be wrong,try messing around that.

Not sure what the exact problem was, but creating a new user profile removed all of the old problems I was having. Must’ve been something weird with the settings or corruption in the account.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.