Portable Manjaro won't boot on one specific machine


I am new to linux so sorry if I have missed something obvious.

I have portable version of manjaro on an ssd in an external enclosure. The other day on my desktop computer I tried to change the ssd card to be the primary boot option. When I turned on the pc it showed the grub display (I think that is what its called) Like the manjaro boot menu, then I selected the first option. But instead of launching there was a grey background with 3 white dots in the top left, then a terminal appeared for maybe 1/3 of a second and then black screen, where it stayed for 30 minutes before I hard shut it down. I reset the defaults on the bios, tried to launch it like normal by spamming f8, but had the exact same thing happen. So I tried to boot from it on my laptop and it is completely fine, I have swapped back between computers 4 times to check, the laptop boots every time perfectly fine, but the desktop goes to a permanent black screen. I have been running this for about a month with no issues, issues happened right after I messed with the bios.

My bios on the desktop is the ASUS ROG UEFI BIOS.

Sorry if that was not as concise as it could be.

Boot fallback initramfs image. (under advanced menu in grub)

To be able to move between systems - you need all open source drivers installed.

Since you tagged the topic with nvidia there is a fair chance your issue is gpu related.

The system on the removable disk must be configured to use opensource drivers only - that is if you want to be sure it can start no matter the system.

That causes the boot to get stuck at the asus logo.

Is this likely to be the issue, as the system worked fine for over a month on this desktop, and only stopped working after I made a bios change?

Then undo the change and check again.

A portable system is not truly portable if a firmware change can make it stop functioning.

As I said in my original post, I have reset the BIOS and the portable os works fine on my 2 laptops, I am actually typing on one now using the portable manjaro. It is just when booting on the desktop that I am presented with issues.

Maybe something else changed too; secure boot turned on, ahci changed to raid, etc. Check bios for ghosts.

1 Like

That indicates a graphics driver issue - boot on a working system - then ensure the gpu driver in use is not proprietary Nvidia - best result is to completely remove the proprietary drivers using mhwd.

Then install the package xorg-drivers

sudo pacman -Syu xorg-drivers

Thank you this worked, however now it is only working on one of my 3 monitors, would you be able to point me in the right direction for debugging these issues?

I don’t know much about the inner workings of Gnome - but you should be able to do something with xrandr.

There is a frontend to xrandr - arandr - which allows you to enable and position your monitors and subsequently save the resulting command line to script file.

This script can then be used to set the layout either automagically or manually.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.