Poor, strange performance with realtek 8168 ethernet

Hey guys, somewhat new to Linux and brand new to Manjaro. Until now, I had been dualbooting Windows and Ubuntu, but today I did a fresh install of Manjaro. One thing I’ve been having problems with is my ethernet adapter; For whatever reason, it seems like pages load at inconsistent speeds. For instance, trying to load a webpage in Firefox (or Vivaldi, for that matter) takes a long time, and then just happens almost at once. Starting a speedtest on Ookla takes forever to start, but once it does, it reports 200mbps down, and so on. I mention having Windows and Ubuntu prior, and it’s because I never noticed this behavior using either.

I’ve googled it, and other people have had trouble with r8168 on Manjaro, but seemingly in different ways. I’ve tried to follow some of the suggestions (reinstall r8168 drivers in Manjaro settings manager and disable ipv6, namely), but those didn’t seem to help.

I’m pretty much a novice with networking, and I’m new to Manjaro, so I’m really not sure what the issue is. Obviously it’s not bottlenecking the speed, since I can get >200mbps on a speed test, but it takes forever to load the speed test itself.

Since I’m sure it’s relevant, I’m on kernel linux512, but this was happening on linux510 as well, and although I’m still uncertain on checking DNS settings on here, my router is configured to 1.1.1.1/1.0.0.1. If there’s any more info I can provide to help diagnose this, I’d be more than happy to.

This looks like a server name resolution problem. Please post the output of:

cat \etc\resolv.conf
pacman -Q | grep resolve

You probably have local name resolution active. I had the same problem a while ago and I solved it by unsetting local name resolution.

[shawn@shawn-manjaro ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.1.43
nameserver 1.1.1.1
nameserver 2001:558:feed::1
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 2001:558:feed::2
[shawn@shawn-manjaro ~]$ pacman -Q | grep resolve
python-resolvelib 0.5.4-1
[shawn@shawn-manjaro ~]$ 

Enter NM configuration for the network you’re connected to and deactivate ipv6.

I had already disabled IPV6, however I wanted to come back to comment since I found my issue. It seems like my router had the default DNS server set to 192.168.1.43 (my old, no-longer-active PiHole IP) and the secondary to 1.1.1.1. I’m assuming that’s why pages loaded slow at first (no response from primary DNS), and would then jump to use secondary DNS any attempt afterwards.
Regardless, I fixed it in both my router and resolv.conf, so my connection’s been solid since.

1 Like