Poor, low sound through HP Omen speaker

I have an HP Omen with Realtek HD Audio (speakers + headphone) and Nvidia HD Audio for a monitor.

The problem: The sound is awful - low volume, flat, narrow soundstage, and low definition using the speakers.

I ran several commands (found in this forum) to determine if I have the right driver.
First I ran xnxi -Ax with the result:
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: sof-audio-pci-intel-cnl bus-ID: 00:1f.3
Device-2: NVIDIA TU104 HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 01:00.1
Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.35 running: yes

Second I ran mhwd -lh -d --pci. This is the result:
23: PCI 1f.3: 0401 Multimedia audio controller
SysFS ID: /devices/pci0000:00/0000:00:1f.3
SysFS BusID: 0000:00:1f.3
Hardware Class: sound
Model: “Intel Comet Lake PCH cAVS”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x06c8 “Comet Lake PCH cAVS”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x8746
Driver: “sof-audio-pci-intel-cnl”
Driver Modules: “snd_sof_pci_intel_cnl”
Memory Range: 0x4042210000-0x4042213fff (rw,non-prefetchable)
Memory Range: 0x4042100000-0x40421fffff (rw,non-prefetchable)
IRQ: 187 (1042 events)
Module Alias: “pci:v00008086d000006C8sv0000103Csd00008746bc04sc01i00”
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: “modprobe snd_hda_intel”
Driver Info #1:
Driver Status: snd_soc_skl is active
Driver Activation Cmd: “modprobe snd_soc_skl”
Driver Info #2:
Driver Status: snd_sof_pci_intel_cnl is active
Driver Activation Cmd: “modprobe snd_sof_pci_intel_cnl”

It was mentioned that Realtek HD driver would be snd_hda_intel. However, it looks like that driver is applying to the NVIDIA Device, which doesn’t drive the headphone or speakers. In fact, Realtek HD isn’t listed at all. Then there is a driver called sof-audio-pci-intel-cnl which is a driver for Intel Comet Lake PCH cAVS.

I’d suggest you to use Pulseeffects to tune the audio to your liking

Audio driver snd_hda_intel has recently been replaced by sof-audio-pci-intel-cnl to support internal digital microphone array (cortana)

There is a modprobe option to force use of the legacy driver, but it would not support the internal microphone and it is unlikely to make any difference to audio quality from speakers

The audio codec and speakers do not have additional audio processing software. The proprietary B&O audio or HP Audio Boost software is not supported.

Sound Open Firmware project might add Linux support for the onboard audio processing in the future but I am not aware of any work on this at the moment

Suggested package pulseffects-legacy might not be working since the last Pulseaudio update
so you might want to try viper4linux-gui
GitHub - Audio4Linux/Viper4Linux-GUI: Official UI for Viper4Linux2

Pulseeffects seems to work but is a complex piece of software that deserves more study. The little I played with it makes me believe that I may be able to solve my audio issues. Likewise, Viper looks promising too. I will need to try both.

Many thanks to both W1sE and nikgnomic!

I do have a follow-up question regarding sounds. On the gnome 40 install I understand there are supposed to be system sounds, but I do not have any. I checked dconf in /org/gnome/desktop/sound/theme-name and changed it to the default, freedesktop, but still no system sounds.

In the sound settings panel the Speaker Test sounds work fine as do the Alert Sounds. All volume output levels are near 100%.

Well this is very odd. In a forum post someone suggested that when this occurs create another admin account. I did just that but the new account didn’t have any sound what-so-ever. Even the speakers were labeled “dummy output”. (Must be some sort of a joke.)

But I switched back to my primary account and all-of-a-sudden I had system sounds. It turns out, though, I have them only when the 2nd account is logged in. Once that account logs out the Primary account’s system sounds vanish.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.