Poor cs:go graphics

Hi, I am Gunit .
Just updated Counter Strike: Global Offence. And got these bad graphics

even in-game got same graphics.
I have played it before the update which was of 150mb download,1.6gb on disk and graphics were fine no lag and no poor graphics

  Kernel: 5.14.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
  root=UUID=3d92a08e-ec54-419d-a9ac-5513127177cd ro quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: herbstluftwm 0.9.3 info: polybar vt: 7 dm: LightDM 1.30.0
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81D6 v: Lenovo ideapad 330-15AST
  serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 330-15AST
  serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55724WIN
  serial: <superuser required> UEFI: LENOVO v: 8UCN19WW date: 05/14/2021
  ID-1: BAT0 charge: 22.4 Wh (100.0%) condition: 22.4/30.6 Wh (73.3%)
  volts: 8.5 min: 7.6 model: CPT-COS L16C2PB2 type: Li-poly serial: <filter>
  status: Full
  RAM: total: 6.67 GiB used: 1.64 GiB (24.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G bits: 64
  type: MCP arch: Excavator family: 15 (21) model-id: 70 (112) stepping: 0
  microcode: 6006705 cache: L1: 256 KiB L2: 2 MiB bogomips: 10402
  Speed: 2571 MHz min/max: 2400/3600 MHz boost: disabled Core speeds (MHz):
  1: 3824 2: 3668
  Flags: 3dnowprefetch abm acc_power aes aperfmperf apic arat avic avx avx2
  bmi1 bmi2 bpext clflush cmov cmp_legacy constant_tsc cpb cpuid cr8_legacy
  cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fma4 fpu
  fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs lahf_lm lbrv lm lwp mca mce
  misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nodeid_msr nonstop_tsc
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
  pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse pse36 ptsc
  rdtscp rep_good sep skinit smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 svm
  svm_lock syscall tbm tce tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
  vmmcall wdt xop xsave xsaveopt
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo
  driver: amdgpu v: kernel bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
  Device-2: IMC Networks EasyCamera type: USB driver: uvcvideo bus-ID: 1-1.3:4
  chip-ID: 13d3:5a02 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: picom v: git-dac85 driver:
  loaded: modesetting display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  OpenGL: renderer: AMD STONEY (DRM 3.42.0 5.14.18-1-MANJARO LLVM 13.0.0)
  v: 4.5 Mesa 21.2.5 direct render: Yes
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:01.1
  chip-ID: 1002:15b3 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
  Sound Server-1: ALSA v: k5.14.18-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 2000
  bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
  driver: r8169 v: kernel port: 1000 bus-ID: 02:00.0 chip-ID: 10ec:8136
  class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 1-1.2:3 chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 103.35 GiB (11.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: LCM2 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUE0N rev: T.02
  dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 315.05 GiB size: 309.11 GiB (98.11%)
  used: 103.24 GiB (33.4%) fs: ext4 dev: /dev/sda9 maj-min: 8:9 label: N/A
  uuid: 3d92a08e-ec54-419d-a9ac-5513127177cd
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
  used: 114 MiB (11.4%) fs: vfat dev: /dev/sda14 maj-min: 8:14 label: N/A
  uuid: 9604-07C2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2.93 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda8 maj-min: 8:8 label: N/A
  uuid: b6b04b23-0477-4459-a870-9c714febfac2
  ID-1: /dev/sda1 maj-min: 8:1 size: 260 MiB fs: vfat label: SYSTEM_DRV
  uuid: 6C8C-D247
  ID-2: /dev/sda10 maj-min: 8:10 size: 195.31 GiB fs: ntfs label: New Volume
  uuid: EEFE8A31FE89F25F
  ID-3: /dev/sda11 maj-min: 8:11 size: 19.29 GiB fs: ntfs label: New Volume
  uuid: 00AC900EAC8FFC7A
  ID-4: /dev/sda12 maj-min: 8:12 size: 2.93 GiB fs: swap label: N/A
  uuid: d491e39d-bb42-43fe-82ab-39fa21701fe8
  ID-5: /dev/sda13 maj-min: 8:13 size: 25 GiB fs: ntfs label: LENOVO
  uuid: 4244764544763C2B
  ID-6: /dev/sda15 maj-min: 8:15 size: 173.09 GiB fs: btrfs label: N/A
  uuid: e7a21b7a-3f64-4fad-89ff-71f881ab13c1
  ID-7: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-8: /dev/sda3 maj-min: 8:3 size: 172.84 GiB fs: ntfs label: Windows
  uuid: 02A48FFDA48FF209
  ID-9: /dev/sda4 maj-min: 8:4 size: 1024 KiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-10: /dev/sda5 maj-min: 8:5 size: 1.5 GiB fs: ntfs label: New Volume
  uuid: 9EFA3429FA33FBD9
  ID-11: /dev/sda6 maj-min: 8:6 size: 954 MiB fs: vfat label: N/A
  uuid: 2D1E-B69F
  ID-12: /dev/sda7 maj-min: 8:7 size: 500 MiB fs: vfat label: N/A
  uuid: 361C-712A
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0
  speed: 480 Mb/s power: 100mA chip-ID: 0438:7900 class-ID: 0900
  Device-1: 1-1.2:3 info: Realtek Bluetooth Radio type: Bluetooth
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
  chip-ID: 0bda:c024 class-ID: e001 serial: <filter>

plz help me fix this

Issue is created on steam community. This issue is for linux and mac :expressionless: :expressionless:

1 Like

And maybe an Kernel update would suffice as well.
Because that one is marked as End of life.

tried 4.14 and 5.10 kernel people have even tried reinstalling and downgrading here Shader pre-caching update: SEVERELY BROKEN on Linux and Mac :: Counter-Strike: Global Offensive General Discussions

Same here waiting for the fix…

I have found this guy who proposes a temporary fix (until Valve does it better way):

It is broken on 5.15 too

Tried no success

I don’t know your system info. Plus I was hopeing someone else would take over.

Seems like it is just a question of time when the problem will be fixed.

Tried some solutions proposed by people here but they do not work, unfortunately.

Edit: at least for me they do not work

I’m having this same problem in Linux Mint 20.2.

And here

I wished the search function was used. This is like the 3rd one.

two bug at valve are reported for both linux and mac
for all discussion check this
a discussion at steam community and this fix works but its not permanent fix so wait for next update and just use this method to run cs:go

Solved by valve

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.