Plymouth: no pixels display after update

I just did a system update and I’m now facing an issue with plymouth.
The theme is not displayed. Instead, I get a blueish-grey graphical-text-like splash, which I guess is a fallback (graphical-text because it’s only text but still looks graphical, unlike the pure text mode).

Using the kernel parameters plymouth:debug, I could see the logs. Apparently, plymouth loads my theme then fails on show-splash: no pixels display. Then it tries the default theme (from /usr/share/plymouth/plymouthd.defaults) and fails the same. Then it uses its internal blueish-grey thing and asks for LUKS password.

I’ve tried a few combinations of kernel and plymouth versions. Here’s what I got:

  • kernel 6.9.2 (from last update) and 6.9.0 (before update)
    • plymouth (latest) : no theme (no pixels display)
    • plymouth (older version): no theme (same)
  • kernel 6.6.32 (lts)
    • plymouth (latest): no display at all, no LUKS prompt
    • plymouth (older version): works perfectly



That was indeed kms. I removed it and now it works. Thanks a lot.

I mean … usually KMS is needed for plymouth.
And is otherwise generally advisable.
But whatever works for you I guess.

1 Like

In fact, for the full story, I usually run without kms because the driver loading causes flickering during the bootloader/plymouth transition.
When I got this issue with plymouth, the first thing I did was to add kms back to the hooks but nothing changed.

My hook has a placeholder (lot of blanks) so I can remember where to put back kms when needed:
HOOKS=(… modconf <-lot of space for kms-> block keyboard kms …)
For some reason, the kms hook was already present after keyboard, which I didn’t see. So during my tests, the system never ran without kms.

Thanks to your message, I double checked and got it right :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.