Plymouth 22.02.122-15 graphical issues

I’ve been struggling with plymouth since the last few weeks after an update.
It used to work like a charm, now it doesn’t.

Please note that the config hasn’t changed and the initramfs does contain my theme.

Using Manjaro’s plymouth package
My theme is not loaded. The default theme is not loaded either. I get a text display where I can enter my luks password. After that, the default splash is displayed (not my theme) for a split second before lightdm kicks in.

Using Manjaro’s plymouth-git package
My theme is now displayed but the font (asking for luks password) is horrible and, more importantly, typing the password is a pain because keystrokes get randomly discarded. I have to check every single keystroke and re-type when they don’t get registered. This never happened before.

That’s very puzzling because plymouth used to work, and I use it on the same computer with both arch and cachy. Both of them work, only Manjaro exhibits this issue.
I’ve checked the versions: arch and cachy both use plymouth-22.02.122-7-x86_64 while Manjaro has plymouth-22.02.122-14-x86_64 and plymouth-22.02.122-15-x86_64 (not available on arch).
I’ve manually installed arch’s plymouth package and everything works again.

Has plymouth been altered by Manjaro?


No such thing … I guess you mean from the Arch User Repository?

The manjaro plymouth package is packaged by/for manjaro.

$ pacman -Si plymouth

Packager        : Mark Wagie <>

To the issues … are you up to date?

sudo pacman-mirrors -f && sudo pacman -Syu

If you are using some AUR package(s) make sure to rebuild them as well.
(or replace them with supported manjaro versions)

Also make sure to rebuild initramfs;

sudo mkinitcpio -P && sudo update-grub

Thanks for your reply.
I’m up-to-date, the initramfs too (I’ve checked with lsinitcpio and everything is inside), and I don’t use grub (I use refind passing the splash kernel parameter).

Something that comes to my mind (looking at the logs),
I don’t use the kms hook as fastboot does not work anymore on Intel drivers, making my screen turn black for a couple of seconds (with flickerings) during the bootloader → plymouth transition. I prefer to use the gop and load the intel driver late (right before lightdm). This worked well until the recent updates in plymouth, and it still works well on arch. If I remember correctly, I added back the kms hook when the problem started but it didn’t fix it, so I removed it. I also increased the DeviceTimeout in plymouth’s config, but it didn’t help.

Basically, if I pacman -S plymouth (installing 22.02.122-15), plymouth is broken.
If I pacman -U ./plymouth-22.02.122-7-x86_64.pkg.tar.zst (package from Arch), it works.

I suggest switching to the unstable branch and testing plymouth 22.02.122-17. It’s now much closer to the Arch package. It’s possible the old cruft left over from the original AUR package could be causing the issue. Arch removed all of it when they imported it, however I kept it around until recently.

If you’d like to test on the stable branch, you can build it yourself:

sudo pacman -Syu --needed base-devel git
git clone
cd plymouth
makepkg -srif

I couldn’t build the package (it requires filesystem>=2023.12.21) so I switched to unstable and it worked. The theme is displayed, the font is ok, and there’s no typing issue for LUKS password. Perfect.

I’ll switch back to stable when 22.02.122-17 is available. Thanks a lot.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.