Plugging an Ethernet cable automatically disables Wifi. How can I stop that?

Hi all.

I have an old Dell Latitude E6530 on which every time I plug an Ethernet cable, wireless network is disabled, which is plainly annoying when I need both adapters to be alive and it’s not an uncommon case for me. How can I prevent that from happening?

Ethernet: Intel 82579LM gigabit (Lewisville)
Wireless: Intel N-6205 (Taylor Peak)
Linux kernel: 6.1.71-1-MANJARO

Thanks in advance.

I don’t think this is done automatically. How do you know it’s actually disconnected/disabled?

My guess is that the default route changes to ethernet which leaves wifi enabled but unsued.

1 Like

Some Dells have a switch on the ethernet socket, disable ‘Wireless Radio Control’ at the ‘Power Management’ section of your Bios. Make sure your Bios is updated.

1 Like

I’ve been looking for such an option for about a decade now, there’s none. The only options that relate to networking is about enabling the onboard NIC (and it’s checked) plus this:

  • Wireless switch: determines which devices are controlled with the RF switch
    → WWAN, WLAN and bluetooth
    [It’s the hardware equivalent for command RFKill]
  • Wireless device enable: controls which wireless devices are available to the operating system
    → same options as above, BT and WLAN are checked

BTW there no longer is any update to the BIOS and it’s the latest one that was available before it was retired.

Well, in this case you’ve learnt something new…

The link I posted was from Dell support; “How to Set up both Wired and Wireless Networks to work simultaneously on a Latitude Laptop.”

Unless you have a specific need like setting a route to an otherwise unreachable network and this happen to a network only reachable by wifi - having two adapters connected to the same network is usually not wanted. Network Manager maintains the switch when eth comes up.

The network is proritized - so look in the network manager seetings panel → generato configuration and set your preferred settings. If you need one the network keep working - change the address assignment from dhcp to manual - set the ip,mask,gateway,nameserver

Remember to cycle network manager ot propagate the new settings.

I think you are overthinking this - hardware switch may be as simple as a switch between two nics.

But consider the suggestion of setting one of the nics to manual ip - the other to dchp.

NetworkManager is likely to execute rfkill to disable one in preference of the other.

1 Like

I had already seen that one. My BIOS doesn’t show the same thing. Regardless, I have unchecked all options under “Wireless Device Enable” and the same behaviour occurs. I cannot have both Ethernet and wireless active together.

That really sucks.

The network manager says “This interface (wireless) was disable by a hardware switch”… which I’ve been trying to identify for that long. Turns out the only hardware switch that is obvious on that machine is the slide switch that controls the devices ticked from the BIOS “Wireless Device Enable”. And, you guessed it, I haven’t touched it, only plugged a network cable.

If it were that simple, I wouldn’t have asked after 10 years I bought the laptop, don’t you think?

I’ve been administering Linux machines since 2004, which is when I switched to Linux on all my machines. I tried so many distros I cannot remember… If it were that simple and if I just had overlooked that switch, I’d have checked that first thing a long time ago, which I did.

The network interface really is disabled. Network manager cannot bring it up again as it’s greyed. I also tried running a Linux distribution without network manager, the wireless device is disabled as soon as I plug a network cable and it gets an IP address.

It is not that simple - if you have been admin for that long then you know all there is right?

Take a look at your configuration in /etc/NetworkManager - assuming you are using NetworkManager

I also consider I can’t know everything, hence I’m asking now, just in case someone, pissed off enough, managed to find a way…

I’ve had an Inspiron 6000 and an XPS before that and I can swear that issue never came out at that time. I guess Dell decided they knew better than their user base…

I already did (check NM /etc directory). Can find nothing relevant there :frowning:

How do we stop this from happening?

Follow the steps below:

  1. In the BIOS setup under Power Management, there is a section for Wireless Radio Control.
  2. You can get to the setup screens by pressing F2 or F12 as your laptop starts up.
  • F2 takes you straight to the BIOS where your touchpad lets you navigate the screens.
  • F12 takes you to a Boot once menu where you can select system setup, which takes you to the same place.
  1. When Wireless Radio Control is enabled, it senses the connection of the laptop to a wired network and then disables the selected wireless radios (WLAN and/or WWAN)
  2. The BIOS default setting is Enabled.
  3. You must set this to Disabled, click on Apply, and then Save and Exit - to boot back to your operating system.
  4. This allows you to have the Wired and a Wireless network active simultaneously.

How to Set up both Wired and Wireless Networks to work simultaneously on a Latitude Laptop. | Dell US

I wouldn’t put it past the vendor and the default OS to have written a configuration the EFI firmware - a lot is possible these days How to Disable a Wireless Network Connection When a Wired Connection is Detected | Dell US

1 Like

This is what I already explained I’ve done (once again, it’s not the first time I come across that article). It changes nothing. That article from Dell is just helpless (besides the fact that my BIOS screen is completely different and the option from the article is not present).

I can only relate to fact you have given - and 99% of the issues on this forum could have been dealt with if the poster did bother searching.

Not in this thread and not in a manner that I have been able to understand.

Then you have a solid hardware issue - and no amount of posting and tellings us how helpless we are - will ever going to change that fact.

If you think you know all and you know there is no solution - why are you asking here - knowing that there is no answer to the issue and there hasn’t been for 10 years.

1 Like

Well, it just p** me off that laptop is the only reliable one I have¹ and that hardware “feature” (bug) being impossible to get rid off just adds insult to injury. Guess I’ll have to suck it and move on :frowning: .

¹ A newer, equivalent Latitude costs more than 6 times that price (i.e. 6000€ !!!) now and I bought a Slimbook that started to give me headaches after only a couple of months (video artifacts, complete lockup that forced me to unscrew the case and unplug the Lithium battery because the power off button didn’t even work any more…oh, and I also forgot that rattling noise from the main fan that makes it impossible to concentrate.) I don’t believe in magic but I’d be cursed it wouldn’t be different.

/rant

Thanks for taking your time anyway. Have a great day.

BTW I see you are prompt to imply I’ve been lazy enough to not search. I understand you cannot trust any random individual who comes asking here but considering everyone as an average joe is not going to work either. I DID bother searching. Been doing that for years and found absolutely nothing¹. What would YOU do in that case?

Drop it?
Or try asking somewhere you have hope someone has an answer?

¹ And if, like me, you are old enough, you now know that finding nothing no longer means there’s no response; it only means it’s buried somewhere in the heap of crap search engines serve you, which has nothing to do with your search criteria anymore.

I am new at this but was wondering, would disabling offloading fix it? NIC