Please Help Me Solve My "sudo" Errors

I am new to Linux and I installed Manjaro a Month before. Everything was running fine but after recent update I started facing some errors:

  1. When I type sudo command in terminal it shows error:

sudo: error in /etc/sudo.conf, line 0 while loading plugin “sudoers_policy”
sudo: unable to load /usr/lib/sudo/ cannot open shared object file: No such file or directory
sudo: fatal error, unable to load plugins

  1. I can’t install or uninstall application from add or remove software
    It simply shows:
    “Authentication Failed”

3.When I try to login after logging out with a correct password, it says that “Unlocking Failed”.

Please Help Me Solve My Problem. Any kind of suggestion accepted
Please Help!!

Considering you reboot your system after update, try this from terminal:
and enter the root password you set at install, then run:
pacman -Syyu sudo libsasl
then reboot the system
systemctl reboot

1 Like

Thanks for responding.
when i write “su” it says:-
“su: Authentication service cannot retrieve authentication info”.

I had entered correct password so no mistake there.
I tried executing it after logging out and logging back in as a root user but then it says:
“Target not found”

Please don’t go into root desktop interface … better do it from TTY.
pacman-mirrors -f5 && pacman -Syyu libsasl


that Worked.Thanks for saving my PC. Very helpful community

I’m marking this thread as solved based on the above.

For future threads, make sure you mark them as solved. You can do that yourself by clicking on the hamburger menu at the bottom of every post (except for the OP). The solution option is hidden there.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.