Please help discover what is freezing my Manjaro daily?

Kernel 5.15, 5.10 XFCE (all up to date rolling stable) video freeze and keyboard network etc stop nothing can be done. Inxi

I was checking journalctl -xe, journalctl -k (k as kernel - alt. to dmesg) but i do not understand or unable to find out any seemingly related line. Rather noob user here.
Can you post here if you are willing to help? I am at the point of considering trying to backup OS drive, re-partition using different OS (maybe Debian rolling) i do not know which OS for this rather new hardware with AMD CPU/GPU.

I have filled numerous other threads that left without reply. No bug tracker here.

1 Like

Everyone here is willing !
You may search in this forum for: How to provide good information, How to get help :wink:
I did change your title to something describing your problem (If you don’t approve, you can change it back) We will see what a word(please) can change !

You are able to include inxi here between backticks 3x(), newline, your text, newline, 3x() (so everyone can read it here without jumping arround)

Have you considered to test another kernel ?

Maybe 5.10 LTS would be a good one to test wehter the kernel changes the problem

1 Like

Yes, same thing happen under 5.10 LTS. Help please

List all of your Hardware. Use the LiveUSB ISO to boot to a Clean State.

I have been having the same problem. The whole system freezes when I play a .mov video taken with my camera. Happens every time. The situation is very low priority so I have not done much investigation. I figured I would just wait till some bugs got swatted in a future update. I use the Nouveau driver, KwinFT, Kernel 5.15x. But now I will start paying attention. Thanks.

1 Like

Manjaro has been freezing up for me (not always - just sometimes) but it always happens when I am playing a video on VLC. One friend sends me MP4 files and his videos are especially prone to freezing my O.S.
After an MP4 freezes things up, the system is more vulnerable after that and often YouTube videos will freeze it…
I did a complete upgrade of files recently and am hopeful of that remedying the intermittent problem I’ve been seeing. If I was to guess the cause, I’d suspect that something in VLC is getting corrupted and playing havoc with the system files. (???)


1 Like

I did already, see the inxi link in 1st post. If not enough, tell me the command to run please. My Manjaro freezes when VLC is not running. I wanted to try install different desktop environment but no one suggested how to proceed.

Postcd, I used to see this on XFCE as well, when I used it. It was not VLC, but mpv I was using for videos. The freezes usually happened while fast-forwarding through a video to check its completeness before playing. I would have to REISUB out of this. It happened rarely, so I couldn’t reproduce it well enough to post about it.

More recently, I have been using sway (5.10 and 5.15) sometimes with mpv. Now, if a file freezes up while fast-forwarding, I can exit normally to the window manager, and then start over.

I don’t have XFCE still on my systems, so I can’t address your problem directly, but my experience suggests it’s not VLC you should be looking at, but something else.

By the way, this was with open source video drivers for Intel.


1 Like

When a system lockup occurs while playing video - it can be caused by a number of reasons

  1. network latency
  2. graphic drivers
  3. the render engine used eg. mpv, mpd, vlc …

Issues with rendering may be solved by using another engine - if it is sub optimal drivers - then there’s really not much you can do - same goes for network latency.

When playing video using the browser on Linux - for what I thnk I know - it is mostly done using software rendering which can put strain on the system. Searching inside the browser about:config may reveal useful switches - where the usability differs from system to system.

@postcd As for your reference to the lack of comments on some of your topics - you should know by now - do not abuse the forum as a resolve for your own laziness.


In this inxi I see an NVMe which seems to be unbranded coz Vendor: SK Hynix
and SK Hynix doesn’t really make consumer product instead they make chips which are then used by vendors like Samsung, San Disk, Kingston ETC.

I have add issue with Kingston and Lexar NVMe as the kernel support is not good cause of the way they use their memory controller.

From my experience, I would advice you to remove the NVMe and test the system and see if it freezes. Also Check what is in the journalctl and dmesg to understand if it throwing nvme related errors.

Good Luck.

1 Like

No, a Forum is no bugtracker. Please be polite, and you will get help everytime it is possible.

1 Like

I suggest you update system BIOS
BIOS and System Firmware - HP ProDesk 400 G6 Desktop Mini PC | HP® Customer Support

I have been away, now turned on the computer made sure BIOS is up to date as suggested by @nikgnomic and after 4 hours computer frozen again.


$ journalctl|grep -i nvm

nvme nvme0: pci function 0000:04:00.0
nvme nvme0: missing or invalid SUBNQN field.
nvme nvme0: 16/0/0 default/read/poll queues
nvme0n1: p1 p2
nvme 0000:04:00.0: platform quirk: setting simple suspend
nvme nvme0: pci function 0000:04:00.0
nvme nvme0: missing or invalid SUBNQN field.
nvme nvme0: 16/0/0 default/read/poll queues
nvme0n1: p1 p2

“quirk” relevant discussion

$ nvme list # ran after installing package nvme-cli

Node                  SN                   Model                                    Namespace Usage                      Format           FW Rev  
--------------------- -------------------- ---------------------------------------- --------- -------------------------- ---------------- --------
/dev/nvme0n1                                                                        1           0,00   B /   0,00   B      1   B +  0 B

Thank you (all), (if you have more ideas on commands, please let me know) i will keep your idea (nvme system drive removal) in mind and if nothing helps and no one have idea on commands to try (to shed some light on freezes) i will consider cloning system drive to a different drive with different size and reorganize drives in computer, but i will do it only if there is no other option/ideas about the freeze cause/commands.

Thank you in advance for command ideas/feedback.

Still freezing, i was considering to
A) cloning the NVMe to HDD, but i have much smaller HDD or larger HDD which i would have to connect via USB 2.0 (there is no other relevant connectors) - i am not sure if it would boot and work. Problem is the drive has full encryption (except /boot?) so different drive size and maybe messing with gparted (i do not need to grow part. just for testing i guess), next issue is figuring out good way to clone it - also it would mean long downtime - slow HDD and all this would maybe tell me that it is freezing even without nvme
B) use Manjaro drive that i have on other computer (swapping the drives), but there would be still differences so would be impossible to tell what causing the freeze. So instead i am thinking to
C) setup new distribution (i think Debian+Gnome - now have xfce) on a HDD and keep this NVMe as a cold backup.

If anyone have more ideas how to record possible cause of the freeze, before i do some stupid thing, let me know please or even via PM (prefered) so we keep this highly on-topic, i will update this with outcomes. Thx

This time computer was running around 36 hours without freezing and i was recording journal output (journalctl -kf >> log). These are like last 60 seconds before freeze… ::

perhaps you can do the same thing again, but this time not just restricted to kernel messages:
journalctl -f >> log1

Just tried and this time frozen under 24 hours, last minute of log lines here please… Please ideas what to try?

I do not know about the relevance of the tor related messages.
In the ~ 20 seconds before the end of the log you ran some user scripts - one as root
check these

Since you are running a zfs raid
(probably not your system on it - not sure)
this could be a source of error
but I have zero experience with both zfs and raid
and do not even begin to know how to make sure that that is working properly and is not the cause of your problems.
I’d check that, if I knew how …

In essence:
I can’t help you.

1 Like