Please help: All files in /home/name immediately appear on desktop

Thanks in advance for anyone willing to help! If nothing else, please post relevant user manuals, I’m happy to do the work reading. I already read the KDE Dolphin manual, but found nothing related.

It seems like the /home/name directory is linked to the desktop. Every file I place in the /home/name directory immediately appears on top left corner of desktop. The files are not located in /home/name/desktop. It does seem like a hard link. If I delete the folder from the desktop, it also deletes in the /home/name.

This happened after I created folders alongside /home/name. I created /home/work and /home/school and home/personal/name. I also moved files from an old windows system with an external hard drive. These had similar names like “documents” “videos” etc. I selected to “overwrite” or “write in” when prompted.

Welcome to the forum! :slight_smile:

Right-click on the desktop and select “Customize Layout” to unlock the widgets. Now right-click the desktop again and choose “Configure Desktop”.

In the section “Wallpaper”, you will see a selection button for “Desktop” or “Folder View”. If you set it to the former, no files will be shown on the desktop. If you set it to the latter, you can select which folder’s contents must be shown on the desktop.

When you’re done, right-click the desktop again and select “Finish Customizing Layout”.

3 Likes

This might help (XDG user directories):
https://wiki.archlinux.org/index.php/XDG_user_directories

Make sure that in the file ~/.config/user-dirs.dirs you have

XDG_DESKTOP_DIR="$HOME/Desktop"
1 Like

Thanks! I was hoping it was a simple fix. I’ve been tinkering so much with preferences that I must have hit that at some point without realizing.

1 Like

Hey thanks so much for your help! Turned out it was just a simple menu toggle. I really appreciate your quick response though.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.