Playback issues with videos over internet

Hi, im a new Manjaro user. I did a fresh dual boot install alongside my W10.
Im stuck on a problem with video playback over internet… When I start a video on Youtube,Twitch,Netflix,etc. its super choppy/laggy and the buffering seems to stop after a few seconds…
I tried using Firefox and Chrome.
I tried and downloaded a video sample and played it in VLC, no problem there, but if I stream anything over the internet from VLC, its choppy again.
I tried downgrading kernel and downgrading NVDIA drivers, no luck.
I tried disabling the composer in xfce, no luck again.

I dont really know how to solve this one, please help !
see inxi output :

inxi -Fza

System: Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=a250ffe7-f1f6-409a-9197-59a34d459c1a rw quiet apparmor=1
security=apparmor resume=UUID=0132acca-267b-45cc-b13c-d42c303a1a7d udev.log_priority=3
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASUSTeK model: SABERTOOTH 990FX R2.0 v: Rev 1.xx serial: BIOS: American Megatrends
v: 2501 date: 04/08/2014
CPU: Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2 stepping: N/A
microcode: 6000852 L2 cache: 2048 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 69384
Speed: 4334 MHz min/max: N/A Core speeds (MHz): 1: 4334 2: 4331 3: 4332 4: 4330 5: 4330 6: 4329 7: 4334 8: 4334
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: NVIDIA GK104 [GeForce GTX 770] vendor: ASUSTeK driver: nvidia v: 450.57 alternate: nouveau,nvidia_drm
bus ID: 01:00.0 chip ID: 10de:1184
Display: x11 server: X.Org 1.20.8 driver: nvidia display ID: :0.0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3") s-diag: 1055mm (41.6")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 96 size: 510x290mm (20.1x11.4") diag: 587mm (23.1")
Monitor-2: DVI-D-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
OpenGL: renderer: GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 450.57 direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:14.2 chip ID: 1002:4383
Device-2: NVIDIA GK104 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:0e0a
Device-3: Kingston HyperX 7.1 Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-2:2
chip ID: 0951:16a4 serial:
Sound Server: ALSA v: k5.8.1-3-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK P8 series driver: r8169 v: kernel
port: b000 bus ID: 0a:00.0 chip ID: 10ec:8168
IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.14 TiB used: 10.83 GiB (0.9%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Western Digital model: WD1003FZEX-00MK2A0 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: 1A01 scheme: MBR
ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 2B6Q scheme: MBR
Partition: ID-1: / raw size: 54.30 GiB size: 53.19 GiB (97.97%) used: 10.83 GiB (20.4%) fs: ext4 dev: /dev/sdb3
Swap: Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.05 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb4
Sensors: System Temperatures: cpu: 26.6 C mobo: N/A gpu: nvidia temp: 38 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info: Processes: 236 Uptime: 26m Memory: 7.68 GiB used: 1.17 GiB (15.3%) Init: systemd v: 245 Compilers: gcc: 10.1.0
Packages: pacman: 1070 lib: 308 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

Since this is the only post about something like this happening and I use Firefox myself i would expect something to be wrong with your connection itself or a hop on the route to the standard servers for your region for Youtube/Amazon.
Could you make a speedtest?

Oh yeah sorry forgot to mention that speedtest reports 60MBs as supposed and that i have no issues whatsoever on my Windows partition.