Plasma Wayland no key repetition in console

Hi,

Key repetition isn’t working in Alacritty, as well as in Konsole. Almost not working, one should say. I’ve seen key repetition once in Alacritty, and once in Konsole. I wasn’t able to see it again, even in the same session. In other apps it seems to be OK.

I use Zsh and IBus.

Where do I have to start the research?

Things to check in System Settings:point_down:

Hardware → Input Devices → Keyboard (Delay and Rate)

Workspace → Startup and Shutdown → Background Services → Keyboard Daemon (must be running)

Another place to see IBus - ArchWiki
And environment variables needed Input method - ArchWiki

While I do not use ibus I have no issues with repeating keys in konsole or anywhere else for that matter.

Using Plasma Wayland

OK and OK. It’s important to mention that in X11 session there’s no problem. It’s my first try with Wayland.

I had to remove those environment variables because of Wayland. It was an express requirement made by IBus daemon. Apparently, those variables are necessary with X11 only.

Perhaps fedora has some insight - they have announced to ditch x11 completely.

Link found on Arch Wiki I18N/InputMethods - Fedora Project Wiki but as Fedora is focused on Gnome - a lot of documentation relates to that.

Maybe it has something to do with IBus. It works, but with a lot of hitches. Mostly in console :slight_smile:

Unfortunately, in Arch Wiki Wayland isn’t even mentioned in IBus context.

1 Like

Plasma KDE plays well with Fcitx5 instead of IBus, can you try it and see if it causes the same problems.

3 Likes

Actually, IBus works with Plasma Wayland seamlessly. Well, except for the key repetition :slight_smile:

  1. Remove the relevant environment variables from /etc/environment:
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
# GTK_IM_MODULE=ibus
# QT_IM_MODULE=ibus
# XMODIFIERS=@im=ibus                                                                                                                                
  1. Check that System Settings > Input Devices > Virtual Keyboard is IBus Wayland.
  2. While you have to deal with X11 as well, add to .xprofile:
...
if [ $XDG_SESSION_TYPE == 'x11' ]; then
    export GTK_IM_MODULE=ibus
    export QT_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    exec /usr/bin/ibus-daemon -rxRd &
fi

Unfortunately, the repetition problem is still there.