Plasma vault does not open correctly, opening with cryfs cli returns [Log] [error] Crashed: Deserialization failed - missing nullbyte for string termination

After a reboot with the vault open, I tried to open the vault from the plasma vault tray icon, it instead opens to the vault, but with no data in it and when I check the tray icon, it says that the vault is not open.
Trying to open the vault with

cryfs /path/to/the/encrypted/data /path/to/vault/mount/point


Filesystem configuration:
- Filesystem format version: 0.10
- Created with: CryFS 0.11.0
- Last opened with: CryFS 0.11.3
- Cipher: xchacha20-poly1305
- Blocksize: 16384 bytes
- Filesystem Id: 953E35A639E869897A3E43FEBD29EBF1
[2022-12-21 11:24:47.285] [Log] [error] Crashed: Deserialization failed - missing nullbyte for string termination

I know that the data still exists somewhere on my drive, because I can see the .enc file and its the same size, but I don’t know how to access it. my other vault made before this happened still works normally.

Thank you for your time, it’s much appreciated

It would look like the encrypted data is corrupted by bad blocks of the disk or filesystem

Seems similar to this CryFS crashes when mounting · Issue #268 · cryfs/cryfs · GitHub
and this KDE Plasma Vaults issue / Newbie Corner / Arch Linux Forums

Default vaults location is ~/.local/share/plasma-vault/
You might need those and try to recover your files using this tool SiriKali works on Linux, macOS and Microsoft Windows Operating Systems | SiriKali then maybe just recreate another vault.

How can I use SiriKali to recover the data?

You build it from AUR
pamac build sirikali

Once is done, you open the UI and then open the encrypted volume/folder from your vaults and enter the password for it and you then should be able to access the files.

It throws the same error as before

in that github issue thread they talked about making a recovery tool for bad blocks, but it doesn’t sound like they are making much progress on it
they also mentioned a tool to recognize issues, and i am trying that out now

  1. Do backup of your encrypted data first.

  2. Delete or move the broken cryfs:

 $ mv ~/.local/share/cryfs ~/Desktop/cryfs_backup

Thanks you very much, this worked, im going to go make some backups now

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.