Plasma-systemmonitor broken in VM when 3D in VBox enabled

As the title suggests.

First of a lot of distros -excluding Arch-based ones like Manjaro- have not marked the package “ksystemstats” as a dependency of plasma-system monitor, which results in the latter not working properly (or at all).

Secondly -and most important- in versions 5.22.5 up to 5.23.2 (the latest in Arch/Manjaro-testing) I tested in all distros I have there is a HUGE memory leak in plasma-system monitor itself, which balloons to over 1G of RAM in just a couple of minutes from just being opened. Tried removing CPU or network sensors but the result is the same. I am able to reproduce this in all distros and in all the above versions, including an untouched KDE neon/testing latest install. This renders the package essentially unusable, since it consumes the entire RAM of the system in a matter of minutes.

Finally, whatever I tried in all versions of the package and in all distros I tested, I cannot for the life of me get pie charts and line charts (eg. in history) to work at all. They are just empty or (in Manjaro) pie charts just show a red background.

For what it’s worth all distros are tested as VMs with VirtualBox 6.1.28 but I can’t see how this would affect things. Even though it will be soon considered deprecated, KSysGuard works in all instances as it is intended.

I don’t see the KDE guys particularly interested in the bugs reported, so just wanted to post this to save someone from countless hours of poking around, like I did.

While the new Plasma System Monitor is great looking and all, I still use KSysGuard, because it’s much lighter and does about the same for me.

1 Like

Did you report bug to KDE developers? I don’t see reports about memory leaks in KDE bugtracker

I can’t reproduce the issue.
I runned system-monitor about 10 minutes without memory leaks.

On which version of plasma-system monitor are you on? Are you sure this is plasma-system monitor and not KSysGyard? Please post the list of dependencies if you are indeed running system-monitor and not KSysGuard.
When I do a plasma-systemmonitor from the cli, I get a continuous stream of QOpenGLShaderProgram warnings, which (seem to) fill the RAM, like this:

QOpenGLShader: link: error: fragment shader uses too many input components (52 > 40)
shader compilation failed:
“error: fragment shader uses too many input components (52 > 40)\n”
QOpenGLShader: link: error: fragment shader uses too many input components (52 > 40)
QOpenGLShaderProgram: uniformLocation(matrix): shader program is not linked

It’s weird, because I can reproduce that in all distros, even in KDE neon (5.23), which is supposed to be pure untouched plasma. Are you on bare metal?

Here is my output in terminal after a couple minutes:

[omano@omano-nvme ~]$ plasma-systemmonitor
kf.kirigami: Units.devicePixelRatio is deprecated (since 5.86 ): This returns 1 when using Qt HiDPI scaling.
file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ScrollView.qml:99:27: QML ScrollBar: Binding loop detected for property "visible"

If I click the categories in the left side menu, some output is added but I don’t have any flood otherwise.

version 5.23.2

This is weird… Does anyone else experience the same? I can reproduce the same thing in Debian testing, KDE neon, Manjaro testing and Kubuntu stable. Can someone please explain the QOpenGLShaderProgram errors?
Are you on a VM or bare metal?

I’m not on a virtual machine.

I’m starting to think that this has something to do with the fact that I’m running plasma on VirtualBox, but I can’t find out what. And I’m not sure. I can’t understand the QOpenGLShaderProgram errors.
I was able to find an older thread from 2017 in Gentoo related to memory leaks in KSysGuard though (I’m not allowed to post links).
That link seems very similar to what I’m experiencing.

Maybe it is related to the “video card” of the virtual machine. Maybe you need to install the Guest Addition or something like that?

I just found out!!! It’s VBox. I had enabled 3D acceleration with VMSVGA and indeed it works fine (I have plasma desktop effects). When I disabled 3D, plasma-systemmonitor worked fine, no memory leaks, pie/line charts working.
But now no desktop effects from plasma (no 3D). I tried changing to VBoxVGA and/or VBoxsVGA but both do not support 3D.
Of course I have Guest additions installed and working properly. Why does system-monitor not work when 3D is enabled? I am then flooded with these QOpenGLShaderProgram errors.
So essentially it’s either system monitor or plasma effects for now…

@ddns what is the theme you’re using?

That was my first thought. I’ve tried multiple themes, I don’t think it’s the theme.
It’s 3D acceleration in VBox, I can reproduce that system monitor works when I disable VBox 3D with Manjaro, Kubuntu and Debian. I’ll change the thread title accordingly.
Of course I’m reverting back to 3D, because if it’s disabled, I completely lose desktop effects from plasma. If someone can reproduce the same when using plasma in a VM, I would appreciate it.
And if someone could explain why this is happening and what these QOpenGLShaderProgram errors mean, that would be much better…:slight_smile:

It’s a custom theme based on Alexey Varfolomeev’s rounded color theme with edited Abyss-Icon-Superpack , customized breeze-dark-gtk and custom colors.

1 Like

thanks,I’m more interested to know how to get those divided panels you have on top?

They are the plasma panels. One is lined up on the right side and the other on the other side,width some separation from edge, both 33% in size.

1 Like

True that! At least in my case.