Plasma style broken (?) after upgrade to 6

Hello!

Today gave in and decided to jump to Manjaro’s testing branch to test the very must awaited Plasma 6. The upgrade went well (I also upgraded from kernel 6.7 to 6.8) but upon rebooting, I immediately noticed the style appeared to be broken. SDDM was different than it was before (no borders, for example), and in normal plasma shell (wayland), a lot of padding, borders and highlights were missing, some widgets seemed to be outdated. Not sure what happened, but it’s definitely not normal.

Here are a couple of example screenshots:


(in this one, I have several of those programs opened, but they don’t look like it)

Any idea what might be causing this?

Thank you!

Remove you old plasma .config files. And cache.

https://wiki.archlinux.org/title/KDE#Plasma_desktop_behaves_strangely

2 Likes

It is virtually essential that you perform some cleanings before/during/after the big upgrade to 6.
As mentioned above.

Beyond that.
Depending on your theme … is it updated for 6?

Similarly, things changed in 6.
The desktop theme (plasma style) now has a lot less power.
The icons in your widgets for example no longer are derived from that plasma style, but from your icon theme.

I’m using regular breeze dark, so that should be good. The icons are also fine, it really is just the lack of padding, highlights, etc, as I mentioned. I will try clearing caches and configs, and see if it helps.

Thank you both so far!

Yes it should not look like that then.

I just checked breeze-dark and it has shadows.

I tried clearing caches (with rm) and configs (by moving to .baks), but the situation seems to persist. In fact, some things seem to have gotten worse hehe, like the task bar becoming way smaller, for some reason.

Any other ideas?

Thanks!

Does that also mean you ran kbuildsycoca6 --noincremental** and restarted ?

(I notice on Archwiki the old kbuildsycoca5 is listed)

The taskbar/panel size is editable too by the way. I found 30px sizes nicely here.

Does that also mean you ran kbuildsycoca6 --noincremental** and restarted ?

Yup, I even tried not doing that too, same result.

I found 30px sizes nicely here.

Interesting, it now defaulted to 30 but I find that way too small, 40/42 seems to be much better :stuck_out_tongue:

Maybe try a fresh new user then and see how that operates.

If still no dice … then I might ask for some system info. Maybe something is awry.

inxi -Farz
1 Like

Create a new user and test with it.

1 Like

I did the same thing last night and found, that a lot of settings are missing (gamma for example) and the whole themeing does not work yet in a lot of places.
I switched back to the stable branch (not downgrading packages) and to the X11 session.
There most of the things still work.

I guess it is to be expected, as testing packages are basically in sync with unstable.

I will either wait, for the issues to resolve as upgraded packages will come to stable eventually, or just might set up my system anew and take the lesson to make use of Timeshift in the future.

Then you didnt change anything on the running system.
(You changed the source of your packages … without changing any of the installed packages.
Your system is still on Plasma 6.)

Besides this.


To the issue at hand - Unless Testing Branch is in a particularly broken state that I am not aware of (running Unstable here) the ‘broken’ appearance is not the result of the state of the packages, but rather some error or incongruent of the existing configuration.

We still wait on OP to respond about the state of a fresh user :slight_smile:

I tried this, but the issue is still there:

inxi -Farz

System:
  Kernel: 6.8.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/root/boot/vmlinuz-6.8-x86_64
    root=UUID=767943ce-1fd1-40ac-8290-109ef2e820fd rw rootflags=subvol=root
    apparmor=1 security=apparmor loglevel=3 udev.log_priority=3
    bootsplash.bootfile=/bootsplash-themes/vendor/bootsplash
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_wayland tools: avail: swayidle,swaylock vt: 7 dm: SDDM
    Distro: Manjaro base: Arch Linux
Machine:
  Type: Laptop System: SchenkerGmbH product: XMG FUSION 15 (XFU15L19)
    v: Late 2019 serial: <superuser required> Chassis: type: 10 v: 1.0
    serial: <superuser required>
  Mobo: Intel model: LAPQC71A v: K54899-304 serial: <superuser required>
    part-nu: XFU15L19 uuid: <superuser required> UEFI: Intel
    v: QCCFL357.0150.2022.0523.1145 date: 05/23/2022
Battery:
  ID-1: BAT0 charge: 74.8 Wh (80.0%) condition: 93.5/93.5 Wh (100.0%)
    volts: 12.0 min: 11.4 model: standard type: Li-ion serial: <filter>
    status: not charging
  Device-1: hidpp_battery_1 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF6
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3104 high: 4300 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4204 2: 4283 3: 4152
    4: 800 5: 800 6: 4288 7: 800 8: 4296 9: 800 10: 4295 11: 4234 12: 4300
    bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS; IBPB: conditional; STIBP: conditional;
    RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Intel
    driver: nvidia v: 550.76 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
    empty: DP-1,DP-2 bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
  Device-3: Chicony HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-13:8 chip-ID: 04f2:b68b
    class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: HDMI-A-1 model: HP X24ih serial: <filter> built: 2022
    res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x297mm (20.75x11.69")
    diag: 605mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: eDP-1 model: BOE Display 0x084d built: 2018 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 2 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm,device-1
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.5-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
    GT2) device-ID: 8086:3e9b memory: 15.1 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.279 layers: 20 device: 0 type: integrated-gpu
    name: Intel UHD Graphics 630 (CFL GT2) driver: mesa intel
    v: 24.0.5-manjaro1.1 device-ID: 8086:3e9b surfaces: xcb,xlib,wayland
    device: 1 type: discrete-gpu name: NVIDIA GeForce GTX 1660 Ti
    driver: nvidia v: 550.76 device-ID: 10de:2191 surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU116 High Definition Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:1aeb
    class-ID: 0403
  API: ALSA v: k6.8.7-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Intel driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 3d:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp61s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 3e:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: br-83f8d0be396f state: down mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:9 chip-ID: 8087:0029
    class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 sub-v: 2184 hci-v: 11 rev: 2184 class-ID: 6c010c
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
    link-mode: peripheral accept service-classes: rendering, capturing, audio,
    telephony
Drives:
  Local Storage: total: 1.36 TiB used: 863.59 GiB (61.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P1SSD8
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR021 temp: 40.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Smart Modular Tech.
    model: SHGP31-1000GM size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 41062C20 temp: 47.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 900 GiB size: 900 GiB (100.00%) used: 863.59 GiB (96.0%)
    fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 452 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:6
  ID-3: /home raw-size: 900 GiB size: 900 GiB (100.00%)
    used: 863.59 GiB (96.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 53.8 C pch: 61.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 3711 fan-2: 3717
Repos:
  Packages: 4908 pm: pacman pkgs: 4890 libs: 668 tools: octopi,pamac,paru,yay
    pm: flatpak pkgs: 18
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: http://ftp.dei.uc.pt/pub/linux/manjaro/testing/$repo/$arch
    2: https://mirrors.up.pt/pub/manjaro/testing/$repo/$arch
Info:
  Memory: total: 16 GiB available: 15.46 GiB used: 4.68 GiB (30.3%)
  Processes: 352 Power: uptime: 34m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.18 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Compilers: clang: 17.0.6 gcc: 13.2.1 alt: 12 Shell: fish v: 3.7.1
    running-in: kitty inxi: 3.3.34

I’m aware, but thx for stating it clearly.

On the X11 session i had some issues to get it running in the first place, but once i resolved that it’s very minor stuff, like no Manjaro icon for the app launcher in my panel (just the KDE default).

Given also the gradient on the background of the widget …

I am beginning to wonder about your compositor.

This looks to me like a compsitor failing. (no transparency, missing shadows, etc)

But if you are using wayland … wayland is the compositor.

I suppose you can hop over to the X11 session for now.
And check that, as well as its compositor settings/availability/status.

I remember the KDE plasma 4 to 5 switch was flawless for me, because i didn’t used Virtual Desktop or Widget’s features… less features, less bugs.

I hope for KDE Plasma 6 the same, but im worried about wayland.
i just hope Manjaro will delay this update till KDE released more patches.

The truth is that Unstable branch is currently the most stable with Plasma 6.0.4, plus everything synchronized with Arch stable repo and compatible with AUR packages.

And use default KDE Breeze theme for Qt, GTK and SDDM, because Manjaro theme is broken.

The issues are also present on X, I forgot to mention, sorry!

@medmedin I believe I already am using Breeze for everything, but I will double check. I guess I could also try hopping to unstable.

Thanks!

I switched to unstable and did a sysupgrade. No differences, as far as I can tell. :confused:

Alright, this is a bit embarrassing… After all, it seems there was just something wrong with the installation. I reinstalled every plasma package through paru -S plasma and everything seems to be good now!

Thanks to everyone who chimed in!