Plasma & SDDM on wayland combo, makes SDDM open up uneccesary new tty on login

At the moment I’ve got both SDDM and Plasma running in Wayland. What I’m trying to do is create a smooth login and logout transition between the two without sudden black screens in and out that is caused by switching tty’s. That looks awful (for me) and is part of the little things that can make feel daily usage of Linux more polished.

Now, since both SDDM and Plasma are running wayland, then why is SDDM opening a new Wayland session in a new tty? Shouldn’t SDDM not just close the greeter and then fire plasma in the same tty by default? I want to make it this way. I have it all set-up as the ARCH manual tells me to.

Any tips on how to achieve that? I’m running latest sddm-git package.

According to

Next, you will need a Wayland compositor (such as KDE’s KWin compositor) to render SDDM, and enter the program and relevant arguments as a parameter to CompositorCommand.

So, in /etc/sddm.conf.d/10-wayland.conf:


More in the section about KDE / KWin

Not using Wayland, I can’t offer more help.


I have no issue with KDE Wayland and SDDM-git when using AMD GPU. No need to use this config /etc/sddm.conf.d/10-wayland.conf
Real freesync works flawlessly on Wayland.

My guess is you use Nvidia GPU, but Nvidia and Wayland are not friends. Switch back to Xorg.

Don’t forget, you should [HowTo] Provide System Information.

Yeah, I did that. It’s all setup like that. Nvidia latest drivers are actually working fine.
It’s really SDDM who’s already running on kwin on wayland, that is opening a new tty and another wayland session. I opened a issue on Github.

1 Like

After some digging, I discovered that no matter what settings you give sddm, it will always start X server. Yes, even if you have set the compositor to Wayland, even if you configure sddm to run in Kwin (running on Wayland), at start of the journal I see that it tried to start x.(and failed).