Plasma-nm package doesn't connect at first attempt

Hi everybody.
I’m new to Manjaro, a few days ago I installed the XFCE version and yesterday I switched to the KDE version with a new install.
When I boot the system, it tries to connect to wifi, but fails. I receive an error telling me something like “interface without file (wlo1) - wireless network can’t be found” (I traslated it from italian, so I’m not 100% sure this is the exact notification one could receive in english). It keeps tryin’ to connect, but failing everytime. At this point, I manually select “disconnect” and then select the same connection. After that, it connects without problems. This happens everytime I boot/reboot.
The system is up to date. I tried different kernels (5.11, 5.10, 5.9, 5.4), but the problem remains.
With the XFCE version I didn’t have this problem, so I can’t tell if it’s KDE-related.

Hello there. I reinstalled last week my system with KDE, after some weeks in Cinnamon and months in Gnome. I got an analog error right after the install (can’t be sure that it’s the exact message).
It’s becoming rare but still happens from time to time. Not each time as for you.

I switch off my Wifi slider and switch back, or as you did, click disconnect in network settings.

There must be some recent KDE-only network glitch.

I think it’s strange I can’t find any bug related to this. Let’s see if someone else’s KDE system is affected.

The problem is likely in the plasma-nm package.
I tried to reinstall it and the connection worked well after the first reboot, while on the second reboot the problem returned. After that, I removed and reinstall the package with the same results: worked well for a couple of boots and then not.
Any suggestion?

This weekend I’ve discovered I could boot my 2011 laptop in UEFI. I’ve reinstalled more than half a dozen times to test refind/systemd-boot/grub in UEFI, in KDE each time, with Architect (unstable branch always) .

Each time I get this error with my WiFi not connected the 1st time I put my WiFi password, and after that, not after every reboot but quite often though.

I tried to reinstall plasma-nm as you suggested @grouchopower, but it still happens sometimes.

There is really an issue here, odd that there is not more people concerned.
On my phone right now, I’ll think to do a screenshot next time.

Here is my screenshot.

Connection xxx deactivated

Wireless interface (wlp3s0)
Impossible to find WiFi network

Hi @grouchopower, we have another KDE user with the same issue.

I put the link here, so that the informations could be shared between the 2 topics.

Thanks. Let’s see if we can find a solution.

I just reinstalled, not with Architect and into Unstable branch, but with the brand new Ornara pre-release iso, with Calamares, so in Stable branch by default.

I entered my WiFi password and it worked, but so far, after each reboot, I still have the issue again. I have to disconnect my non-working connection, launch it again manually and it works.

The culprit is there, somewhere.

[flav@flav-latitudee6520 ~]$ pacman -Qs network 
local/bpytop 1.0.63-1
    Resource monitor that shows usage and stats for processor, memory, disks, network and processes
local/crda 4.14-3
    Central Regulatory Domain Agent for wireless networks
local/glib-networking 2.66.0-1
    Network extensions for GLib
local/gnu-netcat 0.7.1-8
    GNU rewrite of netcat, the network piping application
local/inetutils 1.9.4-8
    A collection of common network programs
local/iputils 20200821-1
    Network monitoring tools, including ping
local/kdeconnect 20.12.3-1 (kde-applications kde-network)
    Adds communication between KDE and your smartphone
local/kdenetwork-filesharing 20.12.3-1 (kde-applications kde-network)
    Properties dialog plugin to share a directory with the local network
local/kget 20.12.3-1 (kde-applications kde-network)
    Download Manager
local/kio 5.80.1-1 (kf5)
    Resource and network access abstraction
local/kio-extras 20.12.3-1 (kde-applications kde-network)
    Additional components to increase the functionality of KIO
local/knewstuff 5.80.0-1 (kf5)
    Support for downloading application assets from the network
local/krb5 1.18.3-1
    The Kerberos network authentication system
local/lib32-krb5 1.18.3-1
    The Kerberos network authentication system (32-bit)
local/lib32-nss 3.62-1
    Network Security Services (32-bit)
local/libnm 1.30.2-1
    NetworkManager client library
local/libteam 1.31-2
    Library for controlling team network device
local/mobile-broadband-provider-info 20201225-1
    Network Management daemon
local/networkmanager 1.30.2-1 (gnome)
    Network connection manager and user applications
local/networkmanager-openconnect 1.2.7dev+49+gc512d5a-1
    NetworkManager VPN plugin for OpenConnect
local/networkmanager-openvpn 1.8.12-1
    NetworkManager VPN plugin for OpenVPN
local/networkmanager-pptp 1.2.9dev+10+gb41b0d0-3
    NetworkManager VPN plugin for PPTP
local/networkmanager-qt 5.80.0-1 (kf5)
    Qt wrapper for NetworkManager API
local/networkmanager-vpnc 1.2.7dev+20+gdca3aea-2
    NetworkManager VPN plugin for VPNC
local/nfs-utils 2.5.3-1
    Support programs for Network File Systems
local/nss 3.62-1
    Network Security Services
local/ntp 4.2.8.p15-1
    Network Time Protocol reference implementation
local/openvpn 2.5.1-1
    An easy-to-use, robust and highly configurable VPN (Virtual Private Network)
local/plasma-nm 5.21.3-1 (plasma)
    Plasma applet written in QML for managing network connections
local/ppp 2.4.8-1
    A daemon which implements the Point-to-Point Protocol for dial-up networking
local/signon-kwallet-extension 20.12.3-1 (kde-applications kde-network)
    KWallet integration for signon framework
local/wget 1.21.1-1
    Network utility to retrieve files from the Web
local/wpa_supplicant 2:2.9-8
    A utility providing key negotiation for WPA wireless networks

Scanning journalctl logs, I found this message, corresponding to the failed attempt to connect after waking from suspension:
wlo1: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
the message recurred with slightly different parameters, probably after every attempt to connect.
I searched for this error massage and found a couple of thread from Arch forum by people with the almost exact problem I described.
This one in particular:
The thread is almost 3 years old, but I found a workaround that seems to work (at least, I rebooted 3 times and it worked everytime):

1 Like

Nice, I will try that.

Wow. Worked instantly after reboot. WiFi connected right after login screen.
Awesome to have found this.

I have been having exactly the same WiFi network connection issues with my two old HP EliteBook laptops (8460p and 8560p). Running Manjaro KDE stable here. Trying different kernels made no difference. Manual connection works most times but not always the first time after coming back from standby. It’s strange that the WiFi card sees all the various networks with good signal strength but just can’t seem to make the actual connection automatically (either my 2.4g or 5g network).

I will read through the Arch Linux page referenced above and see if something there helps. I’ll post back on the results.

UPDATE: Well, that fix didn’t work for me. My WiFi still won’t automatically connect.