Plasma Mobile: Phone calls? Yes. Data? No

When my PinePhone arrived at first, I installed Mobian (which is with Phosh) since at that time it was the only daily driver ready OS.

A few days ago, updates destroyed Mobian completely, I was getting really unhappy with the direction Phosh was heading in over time.
Meanwhile, Manjaro gets more and more stable, so I thought it’s the perfect timing to give Plasma Mobile a try.

Surprisingly, phone calls work perfectly fine without the need to setting APN correctly.
However, there is no internet data without WiFi, and it seems like the settings are hard-locked into specific settings and there appears to be no way to change it.

Any way of getting it to work?

Hello @Famichiki ,

With Wifi switched off, can you issue the following command:

  • “sudo ofonoctl wan --connect --append-dns”
    Then check again if you can browse the internet using your data plan.
    This is also neccasary on my Pinephone when using Plasma Mobile.
    Toggling on/off wifi clears /etc/resolv.conf again, and you have to issue the above command again to get Mobile Data working again.
    Let me know your experience.

Greetings Jasper


It’s working!!
Thanks!! (w>u<)人(>o<w)

1 Like

following the last update I no longer had a telephone service

I applied
sudo systemctl restart ofonoctl

systemctl status ofonoctl

sudo systemctl enable ofonoctl.service

handed over my pine code

then executed what you advocate
sudo ofonoctl wan --connect --append-dns

Really I no longer have a problem

thank for idea

I published on the French forum

A quick update.
Yesterday evening I applied the latest updates, and now it switches between WiFi and 4G automatically.
So we no longer need to manually connect to 4G anymore it seems, great job!

1 Like

The latest update I installed today now:

  1. Adds a triangle icon when on 4G, providing misinformation.
  2. Again requires to manually switch between 4G and WiFi again.
  3. Requires me to reboot sometimes in order to be able to connect, and gives notifications about being unable to find my ISP. But after a reboot I can connect well.

The updates I installed right now resulted in the “sudo ofonoctl wan --connect --append-dns” command to sometimes no longer working, and sometimes it’s working.
So it has just became even more buggier than it already was…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.