Plasma lockscreen not working after update


When I lock my computer, this message appears on a black background:

The screen locker is broken and unlocking is not possible anymore.
In order to unlock switch to a virtual terminal (e.g. Ctrl+Alt+F2), log in and execute the command:
loginctl unlock session 2
Then log out of the virtual session by pressing Ctrl+D, and switch back to the running session (Ctrl+Alt+F1).

So I did what was said and after digging a bit on internet, I ran /usr/lib/kscreenlocker_greet --testing and here’s the output:

/usr/lib/kscreenlocker_greet: symbol lookup error: /usr/lib/kscreenlocker_greet: undefined symbol: _ZN12LayerShellQt6Window16setDesiredOutputEP7QScreen

How can I fix this?

First, I looked on the Plasma / KScreenLocker · GitLab repository, and based on the symbol name _ZN12LayerShellQt6Window16setDesiredOutputEP7QScreen, I found that it was referring to this line:

And the related import is at line 31:

#include <LayerShellQt/Window>

And then I remembered that a long time ago I had tried to build KDE locally and I forgot that I had old KDE-git packages: the “flavor” of layer-shell-qt that I had installed was layer-shell-qt-git.

Installing layer-shell-qt instead of layer-shell-qt-git made it work again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.